summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules4
1 files changed, 2 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 49812fdd2..09dc6e65e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -35,6 +35,7 @@ ifeq ($(DEB_HOST_ARCH_OS),linux)
endif
ifeq (,$(filter terse,$(DEB_BUILD_OPTIONS)))
confflags += --disable-silent-rules
+ testflags += TESTSUITEFLAGS=--verbose
endif
# Enable parallel test suite
@@ -83,8 +84,7 @@ check: build
dh_testdir
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
- cd build-tree && $(MAKE) TESTSUITEFLAGS=--verbose \
- TEST_PARALLEL=$(NUMJOBS) check
+ cd build-tree && $(MAKE) $(testflags) TEST_PARALLEL=$(NUMJOBS) check
endif
# Install the package underneath debian/tmp