summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog1
-rwxr-xr-xdebian/rules1
2 files changed, 2 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 76a1d9894..9c00d50b6 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -132,6 +132,7 @@ dpkg (1.18.11) UNRELEASED; urgency=medium
- Stop compressing the dpkg.deb package with gzip.
- Move dpkg to be the first binary package stanza in debian/control, as
debhelper assigns special meaning by considering it the main package.
+ - Set MAKEFLAGS to -jN from parallel=N in DEB_BUILD_OPTIONS.
* Documentation:
- Update custom changelog parser API support status in README.api.
- Fix typos in docs and man pages. Thanks to Jakub Wilk <jwilk@debian.org>
diff --git a/debian/rules b/debian/rules
index a522afa02..1418d52d5 100755
--- a/debian/rules
+++ b/debian/rules
@@ -41,6 +41,7 @@ endif
NUMJOBS = 1
ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
NUMJOBS = $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
+ MAKEFLAGS += -j$(NUMJOBS)
endif
D := $(CURDIR)/debian/tmp