summaryrefslogtreecommitdiff
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am11
1 files changed, 9 insertions, 2 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index 6871280fe..7f5318b33 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -12,6 +12,7 @@ bin_SCRIPTS = \
dpkg-genchanges \
dpkg-gencontrol \
dpkg-gensymbols \
+ dpkg-maintscript-helper \
dpkg-mergechangelogs \
dpkg-name \
dpkg-parsechangelog \
@@ -25,8 +26,6 @@ if WITH_UPDATE_ALTERNATIVES
bin_SCRIPTS += update-alternatives
endif
-dist_pkglib_SCRIPTS = maintscript-helper
-
changelogdir = $(pkglibdir)/parsechangelog
changelog_SCRIPTS = \
changelog/debian
@@ -41,6 +40,7 @@ EXTRA_DIST = \
dpkg-genchanges.pl \
dpkg-gencontrol.pl \
dpkg-gensymbols.pl \
+ dpkg-maintscript-helper.sh \
dpkg-mergechangelogs.pl \
dpkg-name.pl \
dpkg-parsechangelog.pl \
@@ -123,12 +123,19 @@ do_perl_subst = $(AM_V_GEN) \
-e "s:\$$admindir[[:space:]]*=[[:space:]]*['\"][^'\"]*['\"]:\$$admindir=\"$(admindir)\":" \
-e "s:\$$version[[:space:]]*=[[:space:]]*['\"][^'\"]*[\"']:\$$version=\"$(PACKAGE_VERSION)\":"
+do_shell_subst = $(AM_V_GEN) \
+ sed -e "s:\$$version[[:space:]]*=[[:space:]]*['\"][^'\"]*[\"']:\$$version=\"$(PACKAGE_VERSION)\":"
%: %.pl Makefile
@test -d `dirname $@` || $(mkdir_p) `dirname $@`
$(do_perl_subst) <$< >$@
$(AM_V_at) chmod +x $@
+%: %.sh Makefile
+ @test -d `dirname $@` || $(mkdir_p) `dirname $@`
+ $(do_shell_subst) <$< >$@
+ $(AM_V_at) chmod +x $@
+
install-data-local:
if BUILD_POD_DOC
# Install manual pages for perl modules manually as make can't deal