summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTheodore Ts'o <tytso@mit.edu>2009-04-15 13:05:09 -0400
committerTheodore Ts'o <tytso@mit.edu>2009-04-15 13:12:56 -0400
commit1207e36d0a8674d6c627bb9b2759faf1e290e13e (patch)
treeb0b96aad31b15300ef032e20ee088755f26bc628 /configure.in
parent611378fe20777da83fcc8fe77ff2c515b7dc1e42 (diff)
downloade2fsprogs-1207e36d0a8674d6c627bb9b2759faf1e290e13e.tar.gz
libuuid: Close all file descriptors before running uuidd
This avoids problems when the calling program has open file descriptors (especially sockets) open. Also fix up some warn_unused_result warnings from gcc. Addresses-Launchpad-bug: #305057 Signed-off-by: "Theodore Ts'o" <tytso@mit.edu>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 2534df4c..caf2cb45 100644
--- a/configure.in
+++ b/configure.in
@@ -701,7 +701,7 @@ AC_CHECK_MEMBER(struct sockaddr.sa_len,
[#include <sys/types.h>
#include <sys/socket.h>])
dnl
-AC_CHECK_FUNCS(chflags getrusage llseek lseek64 open64 fstat64 ftruncate64 getmntinfo strtoull strcasecmp srandom jrand48 fchown mallinfo fdatasync strnlen strptime strdup sysconf pathconf posix_memalign memalign valloc __secure_getenv prctl mmap utime setresuid setresgid usleep nanosleep)
+AC_CHECK_FUNCS(chflags getrusage llseek lseek64 open64 fstat64 ftruncate64 getmntinfo strtoull strcasecmp srandom jrand48 fchown mallinfo fdatasync strnlen strptime strdup sysconf pathconf posix_memalign memalign valloc __secure_getenv prctl mmap utime setresuid setresgid usleep nanosleep getdtablesize getrlimit)
dnl
dnl Check to see if -lsocket is required (solaris) to make something
dnl that uses socket() to compile; this is needed for the UUID library