summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTheodore Ts'o <tytso@mit.edu>2008-01-21 13:45:00 -0500
committerTheodore Ts'o <tytso@mit.edu>2008-01-21 13:45:00 -0500
commit261cd3964fe1421bc8b9024c84888a5f1cba4195 (patch)
tree84b7e59e0732e97f1fef8629b6bac7bed3c49387 /configure.in
parent98dca6c552d73cc39a3cb9d16947b2df5c55ef21 (diff)
downloade2fsprogs-261cd3964fe1421bc8b9024c84888a5f1cba4195.tar.gz
Explicitly check for ftruncate64() in configure.in
Apparently Mac OS 10.5 defines fstat64(), but not ftruncate64(), causing resize2fs to fail to build. So check explicitly for ftruncate64(), and fall back to ftruncate() if necessary. Signed-off-by: "Theodore Ts'o" <tytso@mit.edu>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 12baa6b0..799015d2 100644
--- a/configure.in
+++ b/configure.in
@@ -747,7 +747,7 @@ AC_CHECK_MEMBER(struct sockaddr.sa_len,
[#include <sys/types.h>
#include <sys/socket.h>])
dnl
-AC_CHECK_FUNCS(chflags getrusage llseek lseek64 open64 fstat64 getmntinfo strtoull strcasecmp srandom jrand48 fchown mallinfo fdatasync strnlen strptime strdup sysconf pathconf posix_memalign memalign valloc __secure_getenv prctl mmap utime setresuid setresgid)
+AC_CHECK_FUNCS(chflags getrusage llseek lseek64 open64 fstat64 ftruncate64 getmntinfo strtoull strcasecmp srandom jrand48 fchown mallinfo fdatasync strnlen strptime strdup sysconf pathconf posix_memalign memalign valloc __secure_getenv prctl mmap utime setresuid setresgid)
dnl
dnl Check to see if -lsocket is required (solaris) to make something
dnl that uses socket() to compile; this is needed for the UUID library