summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTheodore Ts'o <tytso@mit.edu>2003-03-16 06:26:25 -0500
committerTheodore Ts'o <tytso@mit.edu>2003-03-16 06:26:25 -0500
commit3ae497eab281eab5f98770e6a3d5992b9d37325e (patch)
tree078fb4dfd86d1a323823e783f5a73d0eef0de1f7 /configure.in
parent63182203a757e6b9f5700ea57d9f6e5973251666 (diff)
downloade2fsprogs-3ae497eab281eab5f98770e6a3d5992b9d37325e.tar.gz
Add to the ss (subsystem) library the ability to dynamically link
to the readline library if it is present in the system.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 4047f493..53bb7162 100644
--- a/configure.in
+++ b/configure.in
@@ -625,6 +625,14 @@ SOCKET_LIB=''
AC_CHECK_LIB(socket, socket, [SOCKET_LIB=-lsocket])
AC_SUBST(SOCKET_LIB)
dnl
+dnl Check to see if libdl exists for the sake of dlopen
+dnl
+DLOPEN_LIB=''
+AC_CHECK_LIB(dl, dlopen,
+[DLOPEN_LIB=-ldl
+AC_DEFINE(HAVE_DLOPEN)])
+AC_SUBST(DLOPEN_LIB)
+dnl
dnl See if optreset exists
dnl
AC_MSG_CHECKING(for optreset)