summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorManish Katiyar <mkatiyar@gmail.com>2008-04-14 17:20:03 +0530
committerTheodore Ts'o <tytso@mit.edu>2008-04-21 20:30:48 -0400
commit7321d94eb084ff6164ff3588f86332a420919373 (patch)
tree718e62df372686503d0aea01c415ad08b1abf50a /configure.in
parent8bcaaabb1a023af4852dbf0dba76249982c62e40 (diff)
downloade2fsprogs-7321d94eb084ff6164ff3588f86332a420919373.tar.gz
Fix "make docs" rule in Makefile for doc folder.
Signed-off-by: Manish Katiyar <mkatiyar@gmail.com> Signed-off-by: "Theodore Ts'o" <tytso@mit.edu>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 157816e9..d057af54 100644
--- a/configure.in
+++ b/configure.in
@@ -615,6 +615,20 @@ AC_PATH_PROG(LDCONFIG, ldconfig, :)
AC_CHECK_TOOL(AR, ar, ar)
AC_CHECK_TOOL(RANLIB, ranlib, :)
AC_CHECK_TOOL(STRIP, strip, :)
+AC_CHECK_PROG(MAKEINFO, makeinfo, makeinfo, )
+if test "_$MAKEINFO" = "_"; then
+ MAKEINFO="@echo Makeinfo is missing. Info documentation will not be built.;true"
+else
+ case "$MAKEINFO" in
+ */missing.*)
+ AC_MSG_WARN([
+*** Makeinfo is missing. Info documentation will not be built.])
+ ;;
+ *)
+ ;;
+ esac
+fi
+AC_SUBST(MAKEINFO)
AC_PROG_INSTALL
# See if we need a separate native compiler.
if test $cross_compiling = no; then