summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTheodore Ts'o <tytso@mit.edu>2000-02-02 16:13:14 +0000
committerTheodore Ts'o <tytso@mit.edu>2000-02-02 16:13:14 +0000
commit73ae2d4a23f04e129cd08e29d9124620ad7b4300 (patch)
tree661b419f6ca60b92b6d96f527223a0fba976b823 /configure.in
parent41a817eb13690fb6c7569df462fb9d76028ca9df (diff)
downloade2fsprogs-73ae2d4a23f04e129cd08e29d9124620ad7b4300.tar.gz
ChangeLog, configure, MCONFIG.in, configure.in:
MCONFIG.in: Always include src/include in the include path now. This forces us to use our internally provided ext2_fs.h file, for sanity's sake. configure.in: If linux/fs.h isn't found, then add build/include into the include path only, since src/include is now always included. Removed define of HAVE_LINUX_FS_H, since we're not using it any more. Removed i_version vs. i_generation check, since with the included header file it is a permanently known quantity. Removed AC_C_CROSS since it has been merged into AC_PROG_CC in autoconf 2.13.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in24
1 files changed, 3 insertions, 21 deletions
diff --git a/configure.in b/configure.in
index dfec9f2f..e4ac119e 100644
--- a/configure.in
+++ b/configure.in
@@ -55,6 +55,7 @@ if test -z "$CC" ; then CC=cc; fi
[AC_MSG_RESULT(CC defaults to $CC)])dnl
export CC
AC_SUBST([CC])
+AC_PROG_CC
dnl
dnl set $(LD) from --with-linker=value
dnl
@@ -82,12 +83,8 @@ dnl that holds enough to fake it (hopefully). Note that the $(top_srcdir) here
dnl is quoted so that it gets expanded by make, not by configure.
dnl
AC_CHECK_HEADER(linux/fs.h, [linux_headers=yes], [linux_headers=no])
-if test "$linux_headers" = yes; then
- AC_DEFINE(HAVE_LINUX_FS_H)
-else
- LINUX_INCLUDE='-I$(top_srcdir)/include -I$(top_builddir)/include'
- # Use this include directory with test compiles in the configure script too.
- CPPFLAGS="$CPPFLAGS -I$srcdir/include -I./include"
+if test "$linux_headers" != yes; then
+ LINUX_INCLUDE='-I$(top_builddir)/include'
fi
AC_SUBST(LINUX_INCLUDE)
dnl
@@ -330,9 +327,7 @@ AC_PATH_PROG(PERL, perl, perl)
AC_CHECK_TOOL(AR, ar, ar)
AC_CHECK_TOOL(RANLIB, ranlib, :)
AC_CHECK_TOOL(STRIP, strip, :)
-AC_PROG_CC
AC_PROG_INSTALL
-AC_C_CROSS
# See if we need a separate native compiler.
if test $cross_compiling = no; then
BUILD_CC="$CC"
@@ -469,19 +464,6 @@ if test "$e2fsprogs_cv_ioctl_ext2" = yes; then
AC_DEFINE(HAVE_EXT2_IOCTLS)
fi
dnl
-dnl Check if ext2_inode has i_version (changed to i_generation in Linux 2.3)
-dnl
-AC_MSG_CHECKING(whether struct ext2_inode has an i_version field)
-AC_CACHE_VAL(e2fsprogs_cv_ext2_inode_version,
- AC_TRY_COMPILE([#include <linux/ext2_fs.h>],
- [struct ext2_inode e2i; e2i.i_version=0;],
- [e2fsprogs_cv_ext2_inode_version=yes],
- [e2fsprogs_cv_ext2_inode_version=no]))
-AC_MSG_RESULT($e2fsprogs_cv_ext2_inode_version)
-if test "$e2fsprogs_cv_ext2_inode_version" = yes; then
- AC_DEFINE(HAVE_EXT2_INODE_VERSION)
-fi
-dnl
dnl Linux and Hurd places root files in the / by default
dnl
case "$host_os" in