summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMatthias Andree <matthias.andree@gmx.de>2004-02-23 21:30:11 +0100
committerMatthias Andree <matthias.andree@gmx.de>2004-02-23 21:30:11 +0100
commitb1c92f9121d3b594ea84169235c14f422d3b3ceb (patch)
treed10f8a632871ec08c0647c933ef71510a349ff41 /configure.in
parent151786fc556930246a9d3b3db73c956c786891a1 (diff)
downloade2fsprogs-b1c92f9121d3b594ea84169235c14f422d3b3ceb.tar.gz
Add -mieee to CFLAGS if we're using GCC and the CPU is an Alpha.
Fixes a test case failure in FreeBSD/alpha. Reported and fix suggested by Greg Lewis.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 875f5cf9..6b2d2e98 100644
--- a/configure.in
+++ b/configure.in
@@ -101,6 +101,23 @@ if test "$linux_headers" != yes; then
fi
AC_SUBST(LINUX_INCLUDE)
dnl
+dnl Alpha computers use fast and imprecise floating point code that may
+dnl miss exceptions by default. Force sane options if we're using GCC.
+AC_MSG_CHECKING(for additional special compiler flags)
+if test "$GCC" = yes
+then
+ case "$host_cpu" in
+ alpha) addcflags="-mieee" ;;
+ esac
+fi
+if test "x$addcflags" != x
+then
+ AC_MSG_RESULT($addcflags)
+ CFLAGS="$addcflags $CFLAGS"
+else
+ AC_MSG_RESULT([[(none)]])
+fi
+dnl
dnl Set default values for library extentions. Will be dealt with after
dnl parsing configuration opions, which may modify these
dnl