summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTheodore Ts'o <tytso@mit.edu>2002-05-11 19:17:00 -0400
committerTheodore Ts'o <tytso@mit.edu>2002-05-11 19:17:00 -0400
commitb5ffeadece25f7dca04847dfc013e979fe36e3a6 (patch)
treef4c7c9313788c95e2d6019ad707eea2fc7a56905 /configure.in
parent0f31c737dbf999c90a0842e6a499416b8e1f0cb4 (diff)
downloade2fsprogs-b5ffeadece25f7dca04847dfc013e979fe36e3a6.tar.gz
Integrate ext2ed into the e2fsprogs build system, and make minimal changes so
that it will compile on modern systems. The top-level makefile does not recurse into the ext2ed directory for now, pending determination of whether the original author is still maintaining ext2ed. The documentation files have been renamed to remove the version from the filename. In addition, the SGML files have been converted from LinuxDoc to DocBook. The way root_bindir, root_sbindir, and root_libdir have been changed so that if root_prefix is not set, the values set by the configure command-line options to set the directory names using --bindir, --sbindir, --libdir will affect the root_bindir, et.al Makefile variables.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 15 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 696f3100..3449cdd5 100644
--- a/configure.in
+++ b/configure.in
@@ -596,8 +596,21 @@ if test "$root_prefix" = NONE ; then
else
root_prefix="$prefix"
fi
+ root_bindir=$bindir
+ root_sbindir=$sbindir
+ root_libdir=$libdir
+ root_sysconfdir=$sysconfdir
+else
+ root_bindir='${root_prefix}/bin'
+ root_sbindir='${root_prefix}/sbin'
+ root_libdir='${root_prefix}/lib'
+ root_sysconfdir='${root_prefix}/etc'
fi
AC_SUBST(root_prefix)
+AC_SUBST(root_bindir)
+AC_SUBST(root_sbindir)
+AC_SUBST(root_libdir)
+AC_SUBST(root_sysconfdir)
dnl
dnl See if -static works.
dnl
@@ -655,6 +668,6 @@ if test -d ${srcdir}/resize ; then
fi
AC_OUTPUT(MCONFIG Makefile util/Makefile util/subst.conf lib/et/Makefile
lib/ss/Makefile lib/ext2fs/Makefile lib/e2p/Makefile lib/uuid/Makefile
- misc/Makefile e2fsck/Makefile debugfs/Makefile tests/Makefile
- tests/progs/Makefile $rmakefile doc/Makefile
+ misc/Makefile ext2ed/Makefile e2fsck/Makefile debugfs/Makefile \
+ tests/Makefile tests/progs/Makefile $rmakefile doc/Makefile
intl/Makefile po/Makefile.in)