summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTheodore Ts'o <tytso@mit.edu>2008-02-17 17:36:45 -0500
committerTheodore Ts'o <tytso@mit.edu>2008-02-17 17:36:45 -0500
commitbbf54adb034dbf589d40c4b28c9bb7fe492b87ed (patch)
treef6bfe4c3297dba3a4f458f00f5835c1bae43c875 /configure.in
parent357d1863d64ce807c2904e101fc87d3f6be2f3ca (diff)
parent3eed36b25409dea0cc41c001766456026b5504c8 (diff)
downloade2fsprogs-bbf54adb034dbf589d40c4b28c9bb7fe492b87ed.tar.gz
Merge branch 'maint' into next
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 20f5d16f..756e3bd2 100644
--- a/configure.in
+++ b/configure.in
@@ -41,12 +41,12 @@ esac
base_ver=`echo $E2FSPROGS_VERSION | \
sed -e 's/-WIP//' -e 's/pre-//' -e 's/-PLUS//'`
-pre_vers=`echo $base_ver 0.01 - p | dc`
date_spec=${E2FSPROGS_YEAR}.${MONTH_NUM}.${E2FSPROGS_DAY}
case $E2FSPROGS_VERSION in
*-WIP|pre-*)
+ pre_vers=`echo $base_ver 0.01 - p | dc`
E2FSPROGS_PKGVER="$pre_vers+${base_ver}_WIP_$date_spec"
;;
*)
@@ -603,7 +603,7 @@ if test $cross_compiling = no; then
else
AC_CHECK_PROGS(BUILD_CC, gcc cc)
fi
-AC_CHECK_HEADERS(stdlib.h unistd.h stdarg.h stdint.h errno.h malloc.h mntent.h paths.h dirent.h getopt.h setjmp.h signal.h termios.h linux/fd.h linux/major.h sys/disklabel.h sys/ioctl.h sys/mman.h sys/mkdev.h sys/prctl.h sys/queue.h sys/sockio.h sys/socket.h sys/sysmacros.h sys/time.h sys/stat.h sys/types.h sys/wait.h sys/resource.h sys/syscall.h net/if_dl.h netinet/in.h utime.h)
+AC_CHECK_HEADERS(dirent.h errno.h getopt.h malloc.h mntent.h paths.h setjmp.h signal.h stdarg.h stdint.h stdlib.h termios.h unistd.h utime.h linux/fd.h linux/major.h net/if_dl.h netinet/in.h sys/disklabel.h sys/ioctl.h sys/mkdev.h sys/mman.h sys/prctl.h sys/queue.h sys/resource.h sys/select.h sys/socket.h sys/sockio.h sys/stat.h sys/syscall.h sys/sysmacros.h sys/time.h sys/types.h sys/un.h sys/wait.h)
AC_CHECK_HEADERS(sys/disk.h sys/mount.h,,,
[[
#if HAVE_SYS_QUEUE_H