summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTheodore Ts'o <tytso@mit.edu>2008-07-10 10:21:42 -0400
committerTheodore Ts'o <tytso@mit.edu>2008-07-10 10:21:42 -0400
commiteafba6c3100dee37254573d403f49d9bd88da1e6 (patch)
tree4eb23c5cf6f68e634e4c1c5ce052ad3359a8000f /configure.in
parentf56f32b0a505e34712c8b8fb908dffb616743726 (diff)
downloade2fsprogs-eafba6c3100dee37254573d403f49d9bd88da1e6.tar.gz
Don't use thread local storage if using diet libc
...because the diet libc doesn't support TLS. Addresses-Sourceforge-Bug: #2000654 Signed-off-by: "Theodore Ts'o" <tytso@mit.edu>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 10 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index c16893e6..f8a7edff 100644
--- a/configure.in
+++ b/configure.in
@@ -65,9 +65,11 @@ AC_CANONICAL_HOST
dnl
dnl Use diet libc
dnl
+WITH_DIET_LIBC=
AC_ARG_WITH([diet-libc],
[ --with-diet-libc use diet libc],
CC="diet cc -nostdinc"
+WITH_DIET_LIBC=yes
AC_MSG_RESULT(CC=$CC))dnl
dnl
dnl set $(CC) from --with-cc=value
@@ -529,8 +531,14 @@ else
echo "Enabling thread local support"
fi]
,
-try_tls="yes"
-echo "Try using thread local support by default"
+if test -n "$WITH_DIET_LIBC"
+then
+ try_tls=""
+ echo "Diet libc does not support thread local support"
+else
+ try_tls="yes"
+ echo "Try using thread local support by default"
+fi
)
if test "$try_tls" = "yes"
then