summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTheodore Ts'o <tytso@mit.edu>2003-02-22 13:19:53 -0500
committerTheodore Ts'o <tytso@mit.edu>2003-02-22 13:19:53 -0500
commitf0a22d0fd3ec3f45b562af5afba8811f72b94a28 (patch)
treeb4c9e861df426f86cdea5b932cbb91215b6b585f /configure.in
parent98999c399d563c248728bf217467a788cb0c1aad (diff)
downloade2fsprogs-f0a22d0fd3ec3f45b562af5afba8811f72b94a28.tar.gz
Add dynamic debugging capabilities to the blkid library,
controlled by the environment variable BLKID_DEBUG. The debugging code is enabled by a new configuration option, --enable-blkid-debug.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 1ed81ccd..6428e031 100644
--- a/configure.in
+++ b/configure.in
@@ -334,6 +334,21 @@ fi
echo "Disabling journal debugging by default"
)
dnl
+dnl handle --enable-blkid-debug
+dnl
+AC_ARG_ENABLE([blkid-debug],
+[ --enable-blkid-debug enable blkid debugging],
+if test "$enableval" = "no"
+then
+ echo "Disabling blkid debugging"
+else
+ AC_DEFINE(CONFIG_BLKID_DEBUG)
+ echo "Enabling blkid debugging"
+fi
+,
+echo "Disabling blkid debugging by default"
+)
+dnl
dnl handle --enable-swapfs
dnl
AC_ARG_ENABLE([swapfs],