summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorTheodore Ts'o <tytso@mit.edu>2008-01-27 17:20:44 -0500
committerTheodore Ts'o <tytso@mit.edu>2008-01-27 17:20:44 -0500
commit4f2e8f19827e8b4b9a6b030af8534129cd5e5503 (patch)
treebec4ad827a73766d409d45ec93d0b916ba743986 /debian/rules
parentdf200fffd5276d3c8ba201fd61858ba906b77cf6 (diff)
downloade2fsprogs-4f2e8f19827e8b4b9a6b030af8534129cd5e5503.tar.gz
debian: Don't use dietlibc on platforms that don't support it
Addresses-Debian-Bug: #459475 Signed-off-by: "Theodore Ts'o" <tytso@mit.edu>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules5
1 files changed, 4 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index fe42a52d..b5c00e7b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -112,7 +112,7 @@ STATIC_CONF_FLAGS = --with-ccopts="${CCOPTS}" \
--disable-nls --disable-imager \
--disable-uuidd --disable-tls \
--disable-e2initrd-helper \
- --with-diet-libc --with-ccopts=-fno-stack-protector
+ --with-ccopts=-fno-stack-protector
MIPS_NOPIC_CONF_FLAGS = --with-ccopts="${CCOPTS}" \
--disable-nls \
@@ -180,6 +180,9 @@ ${CFGSTATICSTAMP}:
mkdir -p ${staticbuilddir}
ifeq ($(DEB_BUILD_ARCH),$(DEB_HOST_ARCH))
+ if type diet > /dev/null 2>&1 ; then \
+ STATIC_CONF_FLAGS="$STATIC_CONF_FLAGS --with-diet-libc"; \
+ fi
cd ${staticbuilddir} && AWK=/usr/bin/awk \
${topdir}/configure ${STATIC_CONF_FLAGS}
else