summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorTheodore Ts'o <tytso@mit.edu>2007-09-22 20:42:04 -0400
committerTheodore Ts'o <tytso@mit.edu>2007-09-22 20:43:11 -0400
commit60702c267d83bc75ca22e8efb5eff0e1a8821800 (patch)
treee76ded9dd8a78fae134b987d96c30618097533fc /debian/rules
parented773a263829493e4e4bf612dbec2380cf09349f (diff)
downloade2fsprogs-60702c267d83bc75ca22e8efb5eff0e1a8821800.tar.gz
Work around lame Ubuntu init scripts / installer bugs
The Ubuntu init scripts don't properly set the system time correctly from hardware clock if the hardware clock is configured to tick local time instead of GMT time. Work around this as best as we can by providing an option in /etc/e2fsck.conf which can be set on Ubuntu systems: [options] buggy_init_scripts = 1 Addresses-Debian-Bug: #441093 Addresses-Ubuntu-Bug: #131201 Signed-off-by: "Theodore Ts'o" <tytso@mit.edu>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules6
1 files changed, 6 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index bb3f1d3b..842965e4 100755
--- a/debian/rules
+++ b/debian/rules
@@ -342,6 +342,12 @@ binary-arch: install install-udeb
$(INSTALL) -d ${debdir}/uuid-dev/usr/share/doc/libuuid${UUID_SOVERSION}
+ if test -f /etc/lsb-release && \
+ grep -q DISTRIB_ID=Ubuntu /etc/lsb-release; then \
+ $(INSTALL) -p -m 0644 e2fsck/e2fsck.conf.ubuntu \
+ ${debdir}/e2fsprogs/etc/e2fsck.conf; \
+ fi
+
dh_installinfo -pcomerr-dev ${stdbuilddir}/lib/et/com_err.info
dh_installinfo -pe2fslibs-dev ${stdbuilddir}/doc/libext2fs.info