summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorTheodore Ts'o <tytso@mit.edu>2008-08-25 00:00:35 -0400
committerTheodore Ts'o <tytso@mit.edu>2008-08-25 00:00:35 -0400
commit649bd289d016e4d6db07318145ba488bf7095248 (patch)
tree7b127f3c1f34cf9c7892060267f2ac67f06d062e /debian/rules
parentd56ccbd8f97e90d34a2b18a45fbd6681d3dba726 (diff)
downloade2fsprogs-649bd289d016e4d6db07318145ba488bf7095248.tar.gz
debian: Add dpkg-gensymbols support to track ABI changes to the libraries
Signed-off-by: "Theodore Ts'o" <tytso@mit.edu>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules12
1 files changed, 12 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index df2fe8d8..92295e97 100755
--- a/debian/rules
+++ b/debian/rules
@@ -464,6 +464,18 @@ endif
mv ${libblkiddir}/usr/lib/debug ${libblkiddbgdir}/usr/lib
rmdir ${libblkiddir}/usr/lib
+ # dpkg symbol handling
+ifneq (,$(findstring update-symbols,$(DEB_BUILD_OPTIONS)))
+ for i in e2fslibs libcomerr2 libss2 libblkid1 libuuid1; \
+ do \
+ echo "Generating symbols for $$i..."; \
+ dpkg-gensymbols -p$$i -Pdebian/$$i > debian/$$i.tmp-patch; \
+ cat debian/$$i.tmp-patch; \
+ patch debian/$$i.symbols < debian/$$i.tmp-patch; \
+ /bin/rm debian/$$i.tmp-patch; \
+ done
+endif
+
$(INSTALL) -p -m 0644 debian/e2fsprogs.copyright \
${debugdir}/usr/share/doc/e2fsprogs-dbg/copyright