summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorTheodore Ts'o <tytso@mit.edu>2006-03-29 19:03:38 -0500
committerTheodore Ts'o <tytso@mit.edu>2006-03-29 19:03:38 -0500
commit7512f1366277d89b85c05ee2944a70f8e0a5d970 (patch)
tree7bdbfc5f4e838aa6d65c9a6310191d2bd1ae2986 /debian/rules
parent8ad26b08fac068f0c50d44a5072fb49ab7bedc78 (diff)
downloade2fsprogs-7512f1366277d89b85c05ee2944a70f8e0a5d970.tar.gz
Add udeb: lines to the Debian's shlibs files
Package: e2fsprogs Version: 1.38+1.39-WIP-2005.12.31-1 Severity: wishlist Tags: patch, d-i Let's call this an important wishlist bug (important for Debian Installer anyway :-) Please add the following line to the shlibs files for libblkid and libuuid respectively: udeb: libblkid 1 libblkid1-udeb udeb: libuuid 1 libuuid1-udeb This will allow dpkg/debhelper to properly set the dependencies for udebs that depend on the e2fsprogs libs. Please see #345472 and #345475 for further info on this. This will also mean that, eventually, we will be able to drop the "Provides: ..." for the library udebs, but we cannot do that until other udebs that currently depend on them have been rebuilt. I'll file a separate bug when that change can be made. Addresses Debian Bug: #356293 Signed-off-by: "Theodore Ts'o" <tytso@mit.edu>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules3
1 files changed, 3 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index f8a663d5..d97fcb13 100755
--- a/debian/rules
+++ b/debian/rules
@@ -367,6 +367,9 @@ endif
dh_makeshlibs -Ne2fsprogs-udeb -Nlibblkid1-udeb -Nlibuuid1-udeb
dh_makeshlibs -plibcomerr${COMERR_SOVERSION} \
-V 'libcomerr2 (>= 1.33-3)'
+ echo "udeb: libblkid 1 libblkid1-udeb" >> \
+ debian/libblkid1/DEBIAN/shlibs
+ echo "udeb: libuuid 1 libuuid1-udeb" >> debian/libuuid1/DEBIAN/shlibs
dh_installdeb
dh_shlibdeps -l${stdbuilddir}/lib