summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorTheodore Ts'o <tytso@mit.edu>2003-07-26 00:48:08 -0400
committerTheodore Ts'o <tytso@mit.edu>2003-07-26 00:48:08 -0400
commitf85cc2a8c25d3daa6391cb1aad034a8eafc9e6c0 (patch)
treec86568fa46a96020f1742a545feb42e82af28e73 /debian/rules
parentcf7d5f188643ac56e15d611680b30334bf4c2930 (diff)
downloade2fsprogs-f85cc2a8c25d3daa6391cb1aad034a8eafc9e6c0.tar.gz
Addresses Debian bug #201050. Set the libc-dev dependency correctly
and set DEB_{HOST,BUILD}_* variables correctly for architectures other than *-linux and *-gnu.
Diffstat (limited to 'debian/rules')
-rw-r--r--debian/rules22
1 files changed, 6 insertions, 16 deletions
diff --git a/debian/rules b/debian/rules
index 8a600486..45c6167d 100644
--- a/debian/rules
+++ b/debian/rules
@@ -10,20 +10,12 @@
# be paranoid
export LC_ALL=C
-DEB_BUILD_ARCH := $(shell dpkg --print-architecture)
-DEB_BUILD_GNU_TYPE := $(shell ./config.guess)
-ifndef DEB_HOST_ARCH
- DEB_HOST_ARCH := ${DEB_BUILD_ARCH}
-endif
-DEB_HOST_GNU_CPU := $(patsubst hurd-%,%,$(DEB_HOST_ARCH))
-ifeq ($(filter-out hurd-%,${DEB_HOST_ARCH}),)
- DEB_HOST_GNU_SYSTEM := gnu
-else
-# FIXME: we won't have always just Hurd and Linux
- DEB_HOST_GNU_SYSTEM := linux
-endif
-DEB_HOST_GNU_TYPE := ${DEB_HOST_GNU_CPU}-${DEB_HOST_GNU_SYSTEM}
-
+# These are used for cross-compiling and for saving the configure script
+# from having to guess our platform (since we know it already)
+DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
+DEB_BUILD_ARCH ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH)
+DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
# find the version for the main package, from changelog file
MAIN_VERSION = $(shell head -1 debian/changelog | cut '-d ' -f 2 | sed 's/[()]//g')
@@ -68,7 +60,6 @@ BUILDSTDSTAMP=${STAMPSDIR}/build-std-stamp
BUILDBFSTAMP=${STAMPSDIR}/build-bf-stamp
CCOPTS = -O2 -fsigned-char
-LIBC-DEV = libc6-dev
INSTALL = install
INSTALL_PROGRAM = $(INSTALL) -p -o root -g root -m 755
@@ -82,7 +73,6 @@ endif
ifeq (${DEB_HOST_ARCH},alpha)
CCOPTS += -DHAVE_NETINET_IN_H
-LIBC-DEV = libc6.1-dev
else
CCOPTS += -D__NO_STRING_INLINES
endif