summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorTheodore Ts'o <tytso@mit.edu>2011-09-25 15:40:24 -0400
committerTheodore Ts'o <tytso@mit.edu>2011-09-25 15:40:24 -0400
commit20d7949583a7efbf9b93f7e3d47983e10629530e (patch)
treedb1ba8a1066487a964324f3a5cbc3387471148e4 /debian
parent8a0ef9edfa27c019545f0aff57839a888d0da240 (diff)
downloade2fsprogs-20d7949583a7efbf9b93f7e3d47983e10629530e.tar.gz
debian: don't bomb out if DEB_BUILD_OPTIONS contains nostrip
The debugging packages will contain no debugging symbols (since they are in the unstripped executables and libraries) but at least the build won't crash. Addresses-Debian-Bug: #627535 Signed-off-by: "Theodore Ts'o" <tytso@mit.edu>
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules2
1 files changed, 2 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 84643b5e..6b55b909 100755
--- a/debian/rules
+++ b/debian/rules
@@ -499,6 +499,7 @@ ifneq ($(UTIL_LINUX_NG),yes)
rm -rf ${uuidudebdir}/usr
endif
+ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
mkdir -p ${debugdir}/$(USRLIB)
mv ${maindir}/usr/lib/debug ${debugdir}/$(USRLIB)
rm -rf ${maindir}/usr/lib/debug
@@ -533,6 +534,7 @@ ifneq ($(UTIL_LINUX_NG),yes)
mv ${libblkiddir}/usr/lib/debug ${libblkiddbgdir}/$(USRLIB)
rmdir ${libblkiddir}/usr/lib
endif
+endif
# dpkg symbol handling
ifneq (,$(findstring update-symbols,$(DEB_BUILD_OPTIONS)))