summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorTheodore Ts'o <tytso@mit.edu>2008-09-04 22:39:47 -0400
committerTheodore Ts'o <tytso@mit.edu>2008-09-04 22:39:47 -0400
commit531dfb66b566b223924c897a4be32b529055b327 (patch)
tree783d483b3cbd779e76e57a7ab941c141d4f93c0b /debian
parent29551cacca6df9cd8bcf7223ae4383a27fd23557 (diff)
downloade2fsprogs-531dfb66b566b223924c897a4be32b529055b327.tar.gz
debian: Fix dependencies field in the udeb packages
Addresses-Debian-Bug: #497619 Signed-off-by: "Theodore Ts'o" <tytso@mit.edu>
Diffstat (limited to 'debian')
-rw-r--r--debian/control5
-rw-r--r--debian/e2fsprogs-udeb.shlibs.local2
-rwxr-xr-xdebian/rules1
3 files changed, 5 insertions, 3 deletions
diff --git a/debian/control b/debian/control
index e357e952..a35197bd 100644
--- a/debian/control
+++ b/debian/control
@@ -2,7 +2,7 @@ Source: e2fsprogs
Section: admin
Priority: required
Maintainer: Theodore Y. Ts'o <tytso@mit.edu>
-Build-Depends: texi2html (>= 1.76), gettext, texinfo, dc, pkg-config, dietlibc-dev [alpha amd64 arm hppa i386 ia64 mips mipsel powerpc ppc64 s390 sparc], debhelper (>= 4)
+Build-Depends: texi2html (>= 1.76), gettext, texinfo, dc, pkg-config, dietlibc-dev [alpha amd64 arm hppa i386 ia64 mips mipsel powerpc ppc64 s390 sparc], debhelper (>= 4.2)
Standards-Version: 3.8.0.0
Package: e2fsck-static
@@ -104,6 +104,7 @@ Description: universally unique id library
uuidgen program.
Package: libuuid1-udeb
+XC-Package-Type: udeb
Section: debian-installer
Priority: optional
Depends: ${shlibs:Depends}
@@ -139,6 +140,7 @@ Description: block device id library
system instead.
Package: libblkid1-udeb
+XC-Package-Type: udeb
Section: debian-installer
Priority: optional
Depends: ${shlibs:Depends}
@@ -167,6 +169,7 @@ Description: block device id library - headers and static libraries
This package contains the development environment for the blkid library.
Package: e2fsprogs-udeb
+XC-Package-Type: udeb
Section: debian-installer
Priority: optional
Depends: ${shlibs:Depends}
diff --git a/debian/e2fsprogs-udeb.shlibs.local b/debian/e2fsprogs-udeb.shlibs.local
index 2c6e6fa8..b41b583e 100644
--- a/debian/e2fsprogs-udeb.shlibs.local
+++ b/debian/e2fsprogs-udeb.shlibs.local
@@ -1,6 +1,6 @@
libblkid 1 libblkid1-udeb
# force the dependency to libblkid1-udeb, even if it don't include the lib
libcom_err 2 libblkid1-udeb
-libuuid 1 libblkid1-udeb
+libuuid 1 libuuid1-udeb
libext2fs 2 libblkid1-udeb
libe2p 2 libblkid1-udeb
diff --git a/debian/rules b/debian/rules
index 7b20faf1..f6fd4e5e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -506,7 +506,6 @@ endif
echo "udeb: libuuid 1 libuuid1-udeb" >> debian/libuuid1/DEBIAN/shlibs
dh_installdeb
- rm debian/e2fsprogs-udeb/DEBIAN/conffiles
dh_shlibdeps -l${stdbuilddir}/lib
dh_shlibdeps -pe2fsprogs -l${stdbuilddir}/lib \
-u"-Ldebian/e2fsprogs.shlibs.local"