summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorTheodore Ts'o <tytso@mit.edu>2008-01-30 07:20:54 -0500
committerTheodore Ts'o <tytso@mit.edu>2008-01-30 07:20:54 -0500
commitd8a1a67427ea5778a7b312e1c4d842bdedb50050 (patch)
tree1f8e358be51de8fb6e2959e9cac8e4fd9a9f20b9 /debian
parentc8a5708db1bc66aa361d38e9c74aea929b793921 (diff)
downloade2fsprogs-d8a1a67427ea5778a7b312e1c4d842bdedb50050.tar.gz
debian: Fix packaging problem caused by dpkg 1.14.16
Addresses-Debian-Bug: #436058 Signed-off-by: "Theodore Ts'o" <tytso@mit.edu>
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog10
-rw-r--r--debian/control6
-rwxr-xr-xdebian/rules6
3 files changed, 16 insertions, 6 deletions
diff --git a/debian/changelog b/debian/changelog
index dd5cd7e0..68cb7c84 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,13 @@
+e2fsprogs (1.40.5-2) unstable; urgency=low
+
+ * Fix debian/control and debian/rules so that they work correctly
+ after a change in dpkg-gencontrol's behavior after version 1.14.16
+ of dpkg. This fixes bad version dependencies for comerr-dev,
+ uuid-dev and ss-dev. Thanks to Don Armstrong for the explanation and
+ Margarity Manterola for a proposed patch. (Closes: #463058)
+
+ -- Theodore Y. Ts'o <tytso@mit.edu> Wed, 30 Jan 2008 07:17:27 -0500
+
e2fsprogs (1.40.5-1) unstable; urgency=low
* New upstream release.
diff --git a/debian/control b/debian/control
index 1b1c0f3d..736c1d49 100644
--- a/debian/control
+++ b/debian/control
@@ -36,7 +36,7 @@ Description: common error description library
Package: comerr-dev
Section: libdevel
Priority: extra
-Depends: libc6-dev | libc-dev, libcomerr2 (= ${binary:Version})
+Depends: libc6-dev | libc-dev, libcomerr2 (= ${mainBinary})
Suggests: doc-base
Replaces: e2fslibs-dev (<< 1.33-2), libkrb5-dev (<< 1.3)
Architecture: any
@@ -63,7 +63,7 @@ Description: command-line interface parsing library
Package: ss-dev
Section: libdevel
Priority: extra
-Depends: libc6-dev | libc-dev, libss2 (= ${binary:Version}), comerr-dev
+Depends: libc6-dev | libc-dev, libss2 (= ${mainBinary}), comerr-dev
Architecture: any
Description: command-line interface parsing library - headers and static libraries
This package includes a tool that parses a command table to generate
@@ -112,7 +112,7 @@ Description: universally unique id library
Package: uuid-dev
Section: libdevel
Priority: extra
-Depends: libc6-dev | libc-dev, libuuid1 (= ${binary:Version})
+Depends: libc6-dev | libc-dev, libuuid1 (= ${mainBinary})
Replaces: e2fslibs-dev (<< 1.15)
Architecture: any
Description: universally unique id library - headers and static libraries
diff --git a/debian/rules b/debian/rules
index 6e74c2fe..02f50207 100755
--- a/debian/rules
+++ b/debian/rules
@@ -431,11 +431,11 @@ endif
dh_gencontrol -Ncomerr-dev -Nss-dev -Nuuid-dev \
-Ne2fsprogs-udeb -Nlibblkid1-udeb -Nlibuuid1-udeb
DH_OPTIONS= dh_gencontrol -pcomerr-dev \
- -u '-v${COMERR_VERSION}-${MAIN_VERSION}'
+ -u '-v${COMERR_VERSION}-${MAIN_VERSION} -VmainBinary=${MAIN_VERSION}'
DH_OPTIONS= dh_gencontrol -pss-dev \
- -u '-v${SS_VERSION}-${MAIN_VERSION}'
+ -u '-v${SS_VERSION}-${MAIN_VERSION} -VmainBinary=${MAIN_VERSION}'
DH_OPTIONS= dh_gencontrol -puuid-dev \
- -u '-v${UUID_VERSION}-${MAIN_VERSION}'
+ -u '-v${UUID_VERSION}-${MAIN_VERSION} -VmainBinary=${MAIN_VERSION}'
dh_md5sums -Ne2fsprogs-udeb -Nlibblkid1-udeb -Nlibuuid1-udeb
dh_builddeb -Ne2fsprogs-udeb -Nlibblkid1-udeb -Nlibuuid1-udeb