summaryrefslogtreecommitdiff
path: root/debian/rules.defs
diff options
context:
space:
mode:
authordoko <doko@6ca36cf4-e1d1-0310-8c6f-e303bb2178ca>2013-01-30 01:34:24 +0000
committerdoko <doko@6ca36cf4-e1d1-0310-8c6f-e303bb2178ca>2013-01-30 01:34:24 +0000
commit71783deefda00edc3975857c6230e7c5aa6bd1ed (patch)
treed1af857fad5ad7b5383e7e5d1b7496a52302befe /debian/rules.defs
parent03afd91505b9fd947f7258f50ef69c89c21f27e1 (diff)
downloadgcc-47-71783deefda00edc3975857c6230e7c5aa6bd1ed.tar.gz
* Add a Build-Using attribute for each binary package, which can be
built from the gcc-4.7-source package (patch derived from a proposal by Ansgar Burchardt). - Use it for cross-compiler packages. - Not yet used when building gcj, gdc or gnat using the gcc-source package. These packages don't require an exact version of the gcc-source package, but just a versions which is specifed by the build dependencies. git-svn-id: svn://svn.debian.org/svn/gcccvs/branches/sid/gcc-4.7@6590 6ca36cf4-e1d1-0310-8c6f-e303bb2178ca
Diffstat (limited to 'debian/rules.defs')
-rw-r--r--debian/rules.defs13
1 files changed, 12 insertions, 1 deletions
diff --git a/debian/rules.defs b/debian/rules.defs
index 99d63e4..96b0bdd 100644
--- a/debian/rules.defs
+++ b/debian/rules.defs
@@ -1132,7 +1132,7 @@ endif
ifneq ($(findstring nocheck, $(DEB_BUILD_OPTIONS)),)
with_check := disabled by DEB_BUILD_OPTIONS
endif
-with_check := disabled for this build
+#with_check := disabled for this build
# not a dependency on all archs, but if available, use it for the testsuite
ifneq (,$(wildcard /usr/bin/localedef))
@@ -1459,6 +1459,17 @@ ifeq ($(with_d),yes)
gdc_srcdir := $(patsubst %.tar.xz,%,$(patsubst %.tar.lzma,%,$(patsubst %.tar.gz,%,$(gdc_tarball:.tar.bz2=))))
endif
+# NOTE: This is not yet used. when building gcj, gdc or gnat using the
+# gcc-source package, we don't require an exact binary dependency.
+ifneq ($(dir $(gcc_tarpath)),./)
+ built_using_external_source := yes
+else
+ built_using_external_source :=
+endif
+ifeq ($(DEB_CROSS),yes)
+ add_built_using = yes
+endif
+
ecj_jar := $(firstword $(wildcard ecj.jar /usr/share/java/eclipse-ecj.jar /usr/share/java/ecj.jar))
unpack_stamp := $(stampdir)/01-unpack-stamp