summaryrefslogtreecommitdiff
path: root/debian/rules.defs
diff options
context:
space:
mode:
authordoko <doko@6ca36cf4-e1d1-0310-8c6f-e303bb2178ca>2012-04-25 11:08:54 +0000
committerdoko <doko@6ca36cf4-e1d1-0310-8c6f-e303bb2178ca>2012-04-25 11:08:54 +0000
commitfd6cf33da73434f285d7ed4ecce4cb20eeeb141a (patch)
tree5dcec7fbdd74812347db433e4452c8e3e78e5f4f /debian/rules.defs
parent076ca068c1e19bbc39a830a6df52b1d479872178 (diff)
downloadgcc-47-fd6cf33da73434f285d7ed4ecce4cb20eeeb141a.tar.gz
- refactor setting the ARM target arch
git-svn-id: svn://svn.debian.org/svn/gcccvs/branches/sid/gcc-4.7@5981 6ca36cf4-e1d1-0310-8c6f-e303bb2178ca
Diffstat (limited to 'debian/rules.defs')
-rw-r--r--debian/rules.defs15
1 files changed, 11 insertions, 4 deletions
diff --git a/debian/rules.defs b/debian/rules.defs
index 220221b..fccfcbc 100644
--- a/debian/rules.defs
+++ b/debian/rules.defs
@@ -265,11 +265,14 @@ envfilt = $(strip $(or $(call lfilt,$(1),$(2)),$(call nlfilt,$(1),$(3)),$(call w
# FIXME: libjava is not ported for thumb, this hack only works for
# separate gcj builds
ifeq (,$(findstring gcj,$(PKGSOURCE)))
- ifeq ($(distribution),Ubuntu)
- with_arm_thumb := yes
- endif
ifeq ($(DEB_TARGET_ARCH),armhf)
with_arm_thumb := yes
+ else
+ ifeq ($(distribution)-$(DEB_TARGET_ARCH),Ubuntu-armel)
+ ifneq (,$(filter $(distrelease),lucid maverick natty oneiric precise))
+ with_arm_thumb := yes
+ endif
+ endif
endif
endif
@@ -286,7 +289,11 @@ endif
ifeq ($(DEB_TARGET_ARCH),armhf)
float_abi := hard
else ifneq (,$(filter $(distribution)-$(DEB_TARGET_ARCH), Ubuntu-armel))
- float_abi := softfp
+ ifneq (,$(filter $(distrelease),lucid maverick natty oneiric precise))
+ float_abi := softfp
+ else
+ float_abi := soft
+ endif
else ifneq (,$(filter $(DEB_TARGET_ARCH), arm armel))
float_abi := soft
endif