summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authordoko <doko@6ca36cf4-e1d1-0310-8c6f-e303bb2178ca>2013-06-21 12:41:11 +0000
committerdoko <doko@6ca36cf4-e1d1-0310-8c6f-e303bb2178ca>2013-06-21 12:41:11 +0000
commit1aa674edf05139ea95f3d6428d70eda4995d0024 (patch)
tree56f7af7279746b7058d33eb57a060135ad6bd5a2 /debian
parentb67abc0e96112f61bcbf0f578d830a79bdcda7a7 (diff)
downloadgcc-47-1aa674edf05139ea95f3d6428d70eda4995d0024.tar.gz
* Fix documentation builds with texinfo-5.1.
git-svn-id: svn://svn.debian.org/svn/gcccvs/branches/sid/gcc-4.7@6880 6ca36cf4-e1d1-0310-8c6f-e303bb2178ca
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog1
-rw-r--r--debian/patches/rename-info-files.diff48
2 files changed, 39 insertions, 10 deletions
diff --git a/debian/changelog b/debian/changelog
index 8277017..18f6b0a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -5,6 +5,7 @@ gcc-4.7 (4.7.3-6) UNRELEASED; urgency=low
if the binutils version used for the build cannot be determined.
* For ARM multilib builds, use libsf/libhf system directories to lookup
files for the non-default multilib (for now, only for the cross compilers).
+ * Fix documentation builds with texinfo-5.1.
[ Aurelien Jarno ]
* Don't pass --with-mips-plt on mips/mipsel.
diff --git a/debian/patches/rename-info-files.diff b/debian/patches/rename-info-files.diff
index 6be20e9..e3329d0 100644
--- a/debian/patches/rename-info-files.diff
+++ b/debian/patches/rename-info-files.diff
@@ -93,7 +93,7 @@ Index: b/src/gcc/Makefile.in
===================================================================
--- a/src/gcc/Makefile.in
+++ b/src/gcc/Makefile.in
-@@ -4242,8 +4242,29 @@
+@@ -4258,8 +4258,30 @@
doc: $(BUILD_INFO) $(GENERATED_MANPAGES)
@@ -114,7 +114,8 @@ Index: b/src/gcc/Makefile.in
+ doc/$(INFO_GCCINT_NAME).info \
+ doc/$(INFO_GCCINSTALL_NAME).info doc/$(INFO_CPPINT_NAME).info
+
-+MAKEINFODEFS = -D 'fncpp $(INFO_CPP_NAME)' -D 'fngcc $(INFO_GCC_NAME)' \
++MAKEINFODEFS = -D 'fncpp $(INFO_CPP_NAME)' \
++ -D 'fngcc $(INFO_GCC_NAME)' \
+ -D 'fngxx $(INFO_GXX_NAME)' \
+ -D 'fngccint $(INFO_GCCINT_NAME)' \
+ -D 'fngccinstall $(INFO_GCCINSTALL_NAME)' \
@@ -125,7 +126,28 @@ Index: b/src/gcc/Makefile.in
info: $(INFOFILES) lang.info @GENINSRC@ srcinfo lang.srcinfo
-@@ -4297,21 +4318,41 @@
+@@ -4305,7 +4327,19 @@
+ if [ -n "$(PKGVERSION)" ]; then \
+ echo "@set VERSION_PACKAGE $(PKGVERSION)" >> $@T; \
+ fi
+- echo "@set BUGURL $(BUGURL_TEXI)" >> $@T; \
++ echo "@set BUGURL $(BUGURL_TEXI)" >> $@T
++ ( \
++ echo '@set fncpp $(INFO_CPP_NAME)'; \
++ echo '@set fngcc $(INFO_GCC_NAME)'; \
++ echo '@set fngcov $(INFO_GCC_NAME)'; \
++ echo '@set fngxx $(INFO_GXX_NAME)'; \
++ echo '@set fngccint $(INFO_GCCINT_NAME)'; \
++ echo '@set fngccinstall $(INFO_GCCINSTALL_NAME)'; \
++ echo '@set fncppint $(INFO_CPPINT_NAME)'; \
++ echo '@set fngfortran $(INFO_FORTRAN_NAME)'; \
++ echo '@set fngcj $(INFO_GCJ_NAME)'; \
++ echo '@set fngccgo $(INFO_GCCGO_NAME)'; \
++ ) >> $@T
+ mv -f $@T $@
+
+
+@@ -4313,21 +4347,41 @@
# patterns. To use them, put each of the specific targets with its
# specific dependencies but no build commands.
@@ -174,7 +196,7 @@ Index: b/src/gcc/Makefile.in
-I $(gcc_docdir)/include -o $@ $<; \
fi
-@@ -4672,11 +4713,11 @@
+@@ -4688,11 +4742,11 @@
# $(INSTALL_DATA) might be a relative pathname, so we can't cd into srcdir
# to do the install.
install-info:: doc installdirs \
@@ -191,7 +213,7 @@ Index: b/src/gcc/Makefile.in
lang.install-info
$(DESTDIR)$(infodir)/%.info: doc/%.info installdirs
-@@ -4883,8 +4924,11 @@
+@@ -4899,8 +4953,11 @@
-rm -rf $(DESTDIR)$(bindir)/$(GCOV_INSTALL_NAME)$(exeext)
-rm -rf $(DESTDIR)$(man1dir)/$(GCC_INSTALL_NAME)$(man1ext)
-rm -rf $(DESTDIR)$(man1dir)/cpp$(man1ext)
@@ -322,7 +344,7 @@ Index: b/src/gcc/doc/invoke.texi
===================================================================
--- a/src/gcc/doc/invoke.texi
+++ b/src/gcc/doc/invoke.texi
-@@ -9438,7 +9438,7 @@
+@@ -9442,7 +9442,7 @@
@option{-nodefaultlibs} is @file{libgcc.a}, a library of internal subroutines
which GCC uses to overcome shortcomings of particular machines, or special
needs for some languages.
@@ -331,7 +353,7 @@ Index: b/src/gcc/doc/invoke.texi
Collection (GCC) Internals},
for more discussion of @file{libgcc.a}.)
In most cases, you need @file{libgcc.a} even when you want to avoid
-@@ -9446,7 +9446,7 @@
+@@ -9450,7 +9450,7 @@
or @option{-nodefaultlibs} you should usually specify @option{-lgcc} as well.
This ensures that you have no unresolved references to internal GCC
library subroutines. (For example, @samp{__main}, used to ensure C++
@@ -340,7 +362,7 @@ Index: b/src/gcc/doc/invoke.texi
GNU Compiler Collection (GCC) Internals}.)
@item -pie
-@@ -19656,7 +19656,7 @@
+@@ -19734,7 +19734,7 @@
@option{-B}, @option{-I} and @option{-L} (@pxref{Directory Options}). These
take precedence over places specified using environment variables, which
in turn take precedence over those specified by the configuration of GCC@.
@@ -349,7 +371,7 @@ Index: b/src/gcc/doc/invoke.texi
GNU Compiler Collection (GCC) Internals}.
@table @env
-@@ -19817,7 +19817,7 @@
+@@ -19895,7 +19895,7 @@
A precompiled header file will be searched for when @code{#include} is
seen in the compilation. As it searches for the included file
@@ -672,7 +694,7 @@ Index: b/src/gcc/go/Make-lang.in
-I $(gcc_docdir)/include -o $@ $<; \
else true; fi
-@@ -118,7 +118,7 @@
+@@ -117,7 +118,7 @@
go.all.cross: gccgo-cross$(exeext)
go.start.encap: gccgo$(exeext)
go.rest.encap:
@@ -721,6 +743,8 @@ Index: b/src/gcc/go/gccgo.texi
only documents the options specific to @command{gccgo}.
The @command{gccgo} command may be used to compile Go source code into
+Index: b/src/libquadmath/libquadmath.texi
+===================================================================
--- a/src/libquadmath/libquadmath.texi
+++ b/src/libquadmath/libquadmath.texi
@@ -25,7 +25,7 @@
@@ -732,6 +756,8 @@ Index: b/src/gcc/go/gccgo.texi
@end direntry
This manual documents the GCC Quad-Precision Math Library API.
+Index: b/src/libquadmath/Makefile.am
+===================================================================
--- a/src/libquadmath/Makefile.am
+++ b/src/libquadmath/Makefile.am
@@ -129,22 +129,24 @@
@@ -765,6 +791,8 @@ Index: b/src/gcc/go/gccgo.texi
# Automake Documentation:
+Index: b/src/libquadmath/Makefile.in
+===================================================================
--- a/src/libquadmath/Makefile.in
+++ b/src/libquadmath/Makefile.in
@@ -164,7 +164,8 @@