summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authordoko <doko@6ca36cf4-e1d1-0310-8c6f-e303bb2178ca>2013-04-21 21:40:54 +0000
committerdoko <doko@6ca36cf4-e1d1-0310-8c6f-e303bb2178ca>2013-04-21 21:40:54 +0000
commit383c65c93e1af5aa4e9baa71e7b6cb7d7d036864 (patch)
treec6c77c46e90743dd5582d9166059593089890a9c /debian
parent30c79d2fbad05c0f242ab4027d6e42440aafd703 (diff)
downloadgcc-47-383c65c93e1af5aa4e9baa71e7b6cb7d7d036864.tar.gz
* Fix control file for builds without the x32 multilibs
git-svn-id: svn://svn.debian.org/svn/gcccvs/branches/sid/gcc-4.7@6712 6ca36cf4-e1d1-0310-8c6f-e303bb2178ca
Diffstat (limited to 'debian')
-rw-r--r--debian/control.m412
-rw-r--r--debian/rules.conf1
2 files changed, 9 insertions, 4 deletions
diff --git a/debian/control.m4 b/debian/control.m4
index 53aeed3..f06d5a1 100644
--- a/debian/control.m4
+++ b/debian/control.m4
@@ -643,8 +643,10 @@ ifdef(`TARGET', `dnl
This package contains files for TARGET architecture, for use in cross-compile
environment.
')`'dnl
+')`'dnl libx32gcc
ifenabled(`cdev',`
+ifenabled(`x32dev',`
Package: libx32gcc`'PV-dev`'LS
Architecture: ifdef(`TARGET',`CROSS_ARCH',`biarchx32_archs')
Section: libdevel
@@ -656,8 +658,8 @@ BUILT_USING`'dnl
Description: GCC support library (x32 development files)
This package contains the headers and static library files necessary for
building C programs which use libgcc, libgomp, libquadmath, libssp or libitm.
+')`'dnl x32dev
')`'dnl cdev
-')`'dnl libx32gcc
ifdef(`TARGET', `', `
ifenabled(`libgmath',`
@@ -1758,7 +1760,7 @@ Description: Runtime library for GNU Objective-C applications (n32 development f
This package contains the headers and static library files needed to build
GNU ObjC applications.
-ifenabled(`libx32objc',`
+ifenabled(`x32dev',`
Package: libx32objc`'PV-dev`'LS
Architecture: ifdef(`TARGET',`CROSS_ARCH',`biarchx32_archs')
Section: libdevel
@@ -2053,7 +2055,7 @@ Description: Runtime library for GNU Fortran applications (n32 development files
This package contains the headers and static library files needed to build
GNU Fortran applications.
-ifenabled(`libx32gfortran',`
+ifenabled(`x32dev',`
Package: libx32gfortran`'PV-dev`'LS
Architecture: ifdef(`TARGET',`CROSS_ARCH',`biarchx32_archs')
Section: libdevel
@@ -3037,7 +3039,7 @@ ifdef(`TARGET', `dnl
environment.
')`'dnl
-ifenabled(`libx32dbgcxx',`
+ifenabled(`x32dev',`
Package: libx32stdc++CXX_SO`'PV-dev`'LS
Architecture: ifdef(`TARGET',`CROSS_ARCH',`biarchx32_archs')
Section: ifdef(`TARGET',`devel',`libdevel')
@@ -3060,7 +3062,9 @@ ifdef(`TARGET', `dnl
This package contains files for TARGET architecture, for use in cross-compile
environment.
')`'dnl
+')`'dnl x32dev
+ifenabled(`libx32dbgcxx',`
Package: libx32stdc++CXX_SO`'PV-dbg`'LS
Architecture: ifdef(`TARGET',`CROSS_ARCH',`biarchx32_archs')
Section: debug
diff --git a/debian/rules.conf b/debian/rules.conf
index 5122087..a7a64ff 100644
--- a/debian/rules.conf
+++ b/debian/rules.conf
@@ -636,6 +636,7 @@ addons += cdev c++dev fdev objcdev source objppdev multilib
addons += plugindev
addons += $(if $(findstring armel,$(biarchhfarchs)),armml)
addons += $(if $(findstring armhf,$(biarchsfarchs)),armml)
+addons += $(if $(findstring amd64,$(biarchx32archs)),x32dev)
ifeq ($(with_libgcc),yes)
addons += libgcc lib4gcc lib32gcc lib64gcc libn32gcc
addons += $(if $(findstring amd64,$(biarchx32archs)),libx32gcc)