summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authordoko <doko@6ca36cf4-e1d1-0310-8c6f-e303bb2178ca>2013-05-18 16:59:05 +0000
committerdoko <doko@6ca36cf4-e1d1-0310-8c6f-e303bb2178ca>2013-05-18 16:59:05 +0000
commitb0db42e34d915fbdf29a241111db3cb7b9f2ec7a (patch)
tree847004aa65e9043fcb923fbdeadcf1f4e1e337e4 /debian
parentc81342705cc97073685e065eadbb56cdd4de7bb0 (diff)
downloadgcc-47-b0db42e34d915fbdf29a241111db3cb7b9f2ec7a.tar.gz
* libgo: Overwrite the setcontext_clobbers_tls check on mips*, fails
on some buildds. git-svn-id: svn://svn.debian.org/svn/gcccvs/branches/sid/gcc-4.7@6772 6ca36cf4-e1d1-0310-8c6f-e303bb2178ca
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog2
-rw-r--r--debian/patches/libgo-setcontext-config.diff20
-rw-r--r--debian/rules.patch1
3 files changed, 23 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index caf019e..1a1bd47 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,8 @@ gcc-4.7 (4.7.3-5) UNRELEASED; urgency=low
* Update to SVN 20130517 (r199025) from the gcc-4_7-branch.
* Update the Linaro support to the 4.7-2013.05 release.
+ * libgo: Overwrite the setcontext_clobbers_tls check on mips*, fails
+ on some buildds.
-- Matthias Klose <doko@debian.org> Fri, 17 May 2013 20:53:14 +0200
diff --git a/debian/patches/libgo-setcontext-config.diff b/debian/patches/libgo-setcontext-config.diff
new file mode 100644
index 0000000..599be6b
--- /dev/null
+++ b/debian/patches/libgo-setcontext-config.diff
@@ -0,0 +1,20 @@
+# DP: libgo: Overwrite the setcontext_clobbers_tls check on mips*
+
+--- a/src/libgo/configure.ac
++++ b/src/libgo/configure.ac
+@@ -752,7 +752,15 @@
+ CFLAGS="$CFLAGS_hold"
+ LIBS="$LIBS_hold"
+ ])
++dnl overwrite for the mips* 64bit multilibs, fails on some buildds
+ if test "$libgo_cv_lib_setcontext_clobbers_tls" = "yes"; then
++ case "$target" in
++ mips*-linux-*)
++ AC_MSG_WARN([FIXME: overwrite setcontext_clobbers_tls for $target:$ptr_type_size])
++ libgo_cv_lib_setcontext_clobbers_tls=no ;;
++ esac
++fi
++if test "$libgo_cv_lib_setcontext_clobbers_tls" = "yes"; then
+ AC_DEFINE(SETCONTEXT_CLOBBERS_TLS, 1,
+ [Define if setcontext clobbers TLS variables])
+ fi
diff --git a/debian/rules.patch b/debian/rules.patch
index 2096915..42b61b9 100644
--- a/debian/rules.patch
+++ b/debian/rules.patch
@@ -86,6 +86,7 @@ debian_patches += \
gcc-target-include-asm \
libgcc-backports \
ppl-version \
+ libgo-setcontext-config \
ifneq (,$(filter $(cloog_backend),ppl-0.11))
debian_patches += gcc-cloog-dl