summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
authordoko <doko@6ca36cf4-e1d1-0310-8c6f-e303bb2178ca>2013-06-02 11:55:51 +0000
committerdoko <doko@6ca36cf4-e1d1-0310-8c6f-e303bb2178ca>2013-06-02 11:55:51 +0000
commitdbf0fc79d43487e4fa3cc915450d77b6ba59d211 (patch)
tree36e4425e3dbb561883ed85a8bfab19d5c4b32280 /debian/patches
parentf74e535c42d9da8fb2cc54b96bc3cf5e7698f26f (diff)
downloadgcc-48-dbf0fc79d43487e4fa3cc915450d77b6ba59d211.tar.gz
* Build java packages from this source package. Works aroud ftp-master's
overly strict interpretation of the Built-Using attribute. * Build D and libphobos packages from this source package. git-svn-id: svn://svn.debian.org/svn/gcccvs/branches/sid/gcc-4.8@6800 6ca36cf4-e1d1-0310-8c6f-e303bb2178ca
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/gdc-4.8-doc.diff96
-rw-r--r--debian/patches/gdc-4.8.diff14
-rw-r--r--debian/patches/gdc-libphobos-build.diff16
-rw-r--r--debian/patches/gdc-texinfo.diff53
-rw-r--r--debian/patches/gdc-versym-cpu.diff90
-rw-r--r--debian/patches/gdc-versym-os.diff116
6 files changed, 305 insertions, 80 deletions
diff --git a/debian/patches/gdc-4.8-doc.diff b/debian/patches/gdc-4.8-doc.diff
new file mode 100644
index 0000000..79e37ed
--- /dev/null
+++ b/debian/patches/gdc-4.8-doc.diff
@@ -0,0 +1,96 @@
+# DP: This implements D language support in the GCC back end, and adds
+# DP: relevant documentation about the GDC front end (documentation part).
+
+--- a/src/gcc/doc/frontends.texi
++++ b/src/gcc/doc/frontends.texi
+@@ -9,6 +9,7 @@
+ @cindex GNU Compiler Collection
+ @cindex GNU C Compiler
+ @cindex Ada
++@cindex D
+ @cindex Fortran
+ @cindex Go
+ @cindex Java
+@@ -17,7 +18,7 @@
+ GCC stands for ``GNU Compiler Collection''. GCC is an integrated
+ distribution of compilers for several major programming languages. These
+ languages currently include C, C++, Objective-C, Objective-C++, Java,
+-Fortran, Ada, and Go.
++Fortran, Ada, D and Go.
+
+ The abbreviation @dfn{GCC} has multiple meanings in common use. The
+ current official meaning is ``GNU Compiler Collection'', which refers
+--- a/src/gcc/doc/install.texi
++++ b/src/gcc/doc/install.texi
+@@ -1350,12 +1350,12 @@ their runtime libraries should be built.
+ grep language= */config-lang.in
+ @end smallexample
+ Currently, you can use any of the following:
+-@code{all}, @code{ada}, @code{c}, @code{c++}, @code{fortran},
++@code{all}, @code{ada}, @code{c}, @code{c++}, @code{d}, @code{fortran},
+ @code{go}, @code{java}, @code{objc}, @code{obj-c++}.
+ Building the Ada compiler has special requirements, see below.
+ If you do not pass this flag, or specify the option @code{all}, then all
+ default languages available in the @file{gcc} sub-tree will be configured.
+-Ada, Go and Objective-C++ are not default languages; the rest are.
++Ada, D, Go and Objective-C++ are not default languages; the rest are.
+
+ @item --enable-stage1-languages=@var{lang1},@var{lang2},@dots{}
+ Specify that a particular subset of compilers and their runtime
+--- a/src/gcc/doc/invoke.texi
++++ b/src/gcc/doc/invoke.texi
+@@ -1164,6 +1164,15 @@ called @dfn{specs}.
+ Ada source code file containing a library unit body (a subprogram or
+ package body). Such files are also called @dfn{bodies}.
+
++@item @var{file}.d
++D source code file.
++
++@item @var{file}.di
++D interface code file.
++
++@item @var{file}.dd
++D documentation code file.
++
+ @c GCC also knows about some suffixes for languages not yet included:
+ @c Pascal:
+ @c @var{file}.p
+@@ -1199,6 +1208,7 @@ objective-c objective-c-header objecti
+ objective-c++ objective-c++-header objective-c++-cpp-output
+ assembler assembler-with-cpp
+ ada
++d
+ f77 f77-cpp-input f95 f95-cpp-input
+ go
+ java
+--- a/src/gcc/doc/sourcebuild.texi
++++ b/src/gcc/doc/sourcebuild.texi
+@@ -113,6 +113,9 @@ The Objective-C and Objective-C++ runtim
+ @item libquadmath
+ The runtime support library for quad-precision math operations.
+
++@item libphobos
++The D standard runtime library.
++
+ @item libssp
+ The Stack protector runtime library.
+
+--- a/src/gcc/doc/standards.texi
++++ b/src/gcc/doc/standards.texi
+@@ -288,6 +288,16 @@ a specific version. In general GCC trac
+ closely, and any given release will support the language as of the
+ date that the release was frozen.
+
++@section D language
++
++The D language is under development as of this writing; see the
++@uref{http://dlang.org/@/language-reference.html, current language
++reference}. At present the current major version of D is 2.0, and
++there is no way to describe the language supported by GCC in terms of
++a specific minor version. In general GCC follows the D frontend
++releases closely, and any given GCC release will support the current
++language as of the date that the release was frozen.
++
+ @section References for other languages
+
+ @xref{Top, GNAT Reference Manual, About This Guide, gnat_rm,
diff --git a/debian/patches/gdc-4.8.diff b/debian/patches/gdc-4.8.diff
index b4bc21d..b4b042f 100644
--- a/debian/patches/gdc-4.8.diff
+++ b/debian/patches/gdc-4.8.diff
@@ -1,8 +1,8 @@
# DP: This implements D language support in the GCC back end, and adds
-# DP: relevant documentation about the GDC front end.
+# DP: relevant documentation about the GDC front end (code part).
---- a/src/gcc/config/rs6000/rs6000.c 2013-02-08 19:36:04.000000000 +0000
-+++ b/src/gcc/config/rs6000/rs6000.c 2013-03-20 16:26:18.566235720 +0000
+--- a/src/gcc/config/rs6000/rs6000.c
++++ b/src/gcc/config/rs6000/rs6000.c
@@ -21578,7 +21578,8 @@ rs6000_output_function_epilogue (FILE *f
either, so for now use 0. */
if (! strcmp (language_string, "GNU C")
@@ -13,8 +13,8 @@
i = 0;
else if (! strcmp (language_string, "GNU F77")
|| ! strcmp (language_string, "GNU Fortran"))
---- a/src/gcc/dwarf2out.c 2013-03-05 23:08:45.000000000 +0000
-+++ b/src/gcc/dwarf2out.c 2013-03-20 16:26:18.690235723 +0000
+--- a/src/gcc/dwarf2out.c
++++ b/src/gcc/dwarf2out.c
@@ -18907,6 +18907,8 @@ gen_compile_unit_die (const char *filena
language = DW_LANG_C89;
if (strcmp (language_string, "GNU C++") == 0)
@@ -24,8 +24,8 @@
else if (strcmp (language_string, "GNU F77") == 0)
language = DW_LANG_Fortran77;
else if (strcmp (language_string, "GNU Pascal") == 0)
---- a/src/gcc/gcc.c 2013-03-06 06:32:03.000000000 +0000
-+++ b/src/gcc/gcc.c 2013-03-20 16:26:18.706235722 +0000
+--- a/src/gcc/gcc.c
++++ b/src/gcc/gcc.c
@@ -1002,6 +1002,7 @@ static const struct compiler default_com
{".java", "#Java", 0, 0, 0}, {".class", "#Java", 0, 0, 0},
{".zip", "#Java", 0, 0, 0}, {".jar", "#Java", 0, 0, 0},
diff --git a/debian/patches/gdc-libphobos-build.diff b/debian/patches/gdc-libphobos-build.diff
index 5429fdd..6a49745 100644
--- a/debian/patches/gdc-libphobos-build.diff
+++ b/debian/patches/gdc-libphobos-build.diff
@@ -1,7 +1,7 @@
# DP: This implements building of libphobos library in GCC.
---- a/src/configure 2013-02-15 17:45:54.000000000 +0000
-+++ b/src/configure 2013-03-20 16:26:18.442235719 +0000
+--- a/src/configure
++++ b/src/configure
@@ -2781,7 +2781,8 @@ target_libraries="target-libgcc \
${libgcj} \
target-libobjc \
@@ -12,8 +12,8 @@
# these tools are built using the target libraries, and are intended to
# run only in the target environment
---- a/src/configure.ac 2013-02-15 17:45:54.000000000 +0000
-+++ b/src/configure.ac 2013-03-20 16:26:18.462235720 +0000
+--- a/src/configure.ac
++++ b/src/configure.ac
@@ -168,7 +168,8 @@ target_libraries="target-libgcc \
${libgcj} \
target-libobjc \
@@ -24,8 +24,8 @@
# these tools are built using the target libraries, and are intended to
# run only in the target environment
---- a/src/Makefile.def 2013-01-14 16:15:21.000000000 +0000
-+++ b/src/Makefile.def 2013-03-20 16:26:18.466235720 +0000
+--- a/src/Makefile.def
++++ b/src/Makefile.def
@@ -131,6 +131,7 @@ target_modules = { module= libquadmath;
target_modules = { module= libgfortran; };
target_modules = { module= libobjc; };
@@ -52,8 +52,8 @@
// Toplevel bootstrap
bootstrap_stage = { id=1 ; };
---- a/src/Makefile.in 2013-01-14 16:15:21.000000000 +0000
-+++ b/src/Makefile.in 2013-03-20 16:26:18.514235720 +0000
+--- a/src/Makefile.in
++++ b/src/Makefile.in
@@ -933,6 +933,7 @@ configure-target: \
maybe-configure-target-libgfortran \
maybe-configure-target-libobjc \
diff --git a/debian/patches/gdc-texinfo.diff b/debian/patches/gdc-texinfo.diff
new file mode 100644
index 0000000..dcd1153
--- /dev/null
+++ b/debian/patches/gdc-texinfo.diff
@@ -0,0 +1,53 @@
+# DP: Add macros for the gdc texinfo documentation.
+
+--- a/src/gcc/d/gdc.texi
++++ b/src/gcc/d/gdc.texi
+@@ -43,6 +43,22 @@
+ @insertcopying
+ @end ifinfo
+
++@macro versionsubtitle
++@ifclear DEVELOPMENT
++@subtitle For @sc{gcc} version @value{version-GCC}
++@end ifclear
++@ifset DEVELOPMENT
++@subtitle For @sc{gcc} version @value{version-GCC} (pre-release)
++@end ifset
++@ifset VERSION_PACKAGE
++@sp 1
++@subtitle @value{VERSION_PACKAGE}
++@end ifset
++@c Even if there are no authors, the second titlepage line should be
++@c forced to the bottom of the page.
++@vskip 0pt plus 1filll
++@end macro
++
+ @titlepage
+ @title The GNU D Compiler
+ @versionsubtitle
+@@ -138,6 +154,25 @@
+
+ @c man end
+
++@macro gcctabopt{body}
++@code{\body\}
++@end macro
++@macro gccoptlist{body}
++@smallexample
++\body\
++@end smallexample
++@end macro
++@c Makeinfo handles the above macro OK, TeX needs manual line breaks;
++@c they get lost at some point in handling the macro. But if @macro is
++@c used here rather than @alias, it produces double line breaks.
++@iftex
++@alias gol = *
++@end iftex
++@ifnottex
++@macro gol
++@end macro
++@end ifnottex
++
+ @c man begin OPTIONS gdc
+
+ @table @gcctabopt
diff --git a/debian/patches/gdc-versym-cpu.diff b/debian/patches/gdc-versym-cpu.diff
index 48c0d84..b2ac9a9 100644
--- a/debian/patches/gdc-versym-cpu.diff
+++ b/debian/patches/gdc-versym-cpu.diff
@@ -1,7 +1,50 @@
# DP: Implements D CPU version conditions.
---- a/src/gcc/config/aarch64/aarch64.h 2013-01-10 20:38:27.000000000 +0000
-+++ b/src/gcc/config/aarch64/aarch64.h 2013-03-20 16:26:18.726235723 +0000
+This implements the following versions:
+* D_HardFloat
+* D_SoftFloat
+
+for all supported architectures. And these where appropriate:
+* ARM
+** ARM_Thumb
+** ARM_HardFloat
+** ARM_SoftFloat
+** ARM_SoftFP
+* AArch64
+* Alpha
+** Alpha_SoftFloat
+** Alpha_HardFloat
+* X86
+* X86_64
+** D_X32
+* IA64
+* MIPS32
+* MIPS64
+** MIPS_O32
+** MIPS_O64
+** MIPS_N32
+** MIPS_N64
+** MIPS_EABI
+** MIPS_HardFloat
+** MIPS_SoftFloat
+* HPPA
+* HPPA64
+* PPC
+* PPC64
+** PPC_HardFloat
+** PPC_SoftFloat
+* S390
+* S390X
+* SH
+* SH64
+* SPARC
+* SPARC64
+* SPARC_V8Plus
+** SPARC_HardFloat
+** SPARC_SoftFloat
+
+--- a/src/gcc/config/aarch64/aarch64.h
++++ b/src/gcc/config/aarch64/aarch64.h
@@ -51,6 +51,14 @@
\
} while (0)
@@ -17,8 +60,8 @@
/* Target machine storage layout. */
---- a/src/gcc/config/alpha/alpha.h 2013-01-10 20:38:27.000000000 +0000
-+++ b/src/gcc/config/alpha/alpha.h 2013-03-20 16:26:18.734235722 +0000
+--- a/src/gcc/config/alpha/alpha.h
++++ b/src/gcc/config/alpha/alpha.h
@@ -72,6 +72,23 @@ along with GCC; see the file COPYING3.
SUBTARGET_LANGUAGE_CPP_BUILTINS(); \
} while (0)
@@ -43,8 +86,8 @@
#ifndef SUBTARGET_LANGUAGE_CPP_BUILTINS
#define SUBTARGET_LANGUAGE_CPP_BUILTINS() \
do \
---- a/src/gcc/config/arm/arm.h 2013-01-15 16:17:28.000000000 +0000
-+++ b/src/gcc/config/arm/arm.h 2013-03-20 16:26:18.746235724 +0000
+--- a/src/gcc/config/arm/arm.h
++++ b/src/gcc/config/arm/arm.h
@@ -158,6 +158,31 @@ extern char arm_arch_name[];
builtin_define ("__ARM_ARCH_EXT_IDIV__"); \
} while (0)
@@ -77,8 +120,8 @@
#include "config/arm/arm-opts.h"
enum target_cpus
---- a/src/gcc/config/i386/i386.h 2013-01-28 20:42:55.000000000 +0000
-+++ b/src/gcc/config/i386/i386.h 2013-03-20 16:26:18.754235724 +0000
+--- a/src/gcc/config/i386/i386.h
++++ b/src/gcc/config/i386/i386.h
@@ -588,6 +588,24 @@ extern const char *host_detect_local_cpu
/* Target CPU builtins. */
#define TARGET_CPU_CPP_BUILTINS() ix86_target_macros ()
@@ -104,8 +147,8 @@
/* Target Pragmas. */
#define REGISTER_TARGET_PRAGMAS() ix86_register_pragmas ()
---- a/src/gcc/config/ia64/ia64.h 2013-01-10 20:38:27.000000000 +0000
-+++ b/src/gcc/config/ia64/ia64.h 2013-03-20 16:26:18.766235724 +0000
+--- a/src/gcc/config/ia64/ia64.h
++++ b/src/gcc/config/ia64/ia64.h
@@ -40,6 +40,13 @@ do { \
builtin_define("__BIG_ENDIAN__"); \
} while (0)
@@ -120,8 +163,8 @@
#ifndef SUBTARGET_EXTRA_SPECS
#define SUBTARGET_EXTRA_SPECS
#endif
---- a/src/gcc/config/mips/mips.h 2013-02-25 13:53:16.000000000 +0000
-+++ b/src/gcc/config/mips/mips.h 2013-03-20 16:26:18.778235723 +0000
+--- a/src/gcc/config/mips/mips.h
++++ b/src/gcc/config/mips/mips.h
@@ -551,6 +551,54 @@ struct mips_cpu_info {
} \
while (0)
@@ -177,8 +220,8 @@
/* Default target_flags if no switches are specified */
#ifndef TARGET_DEFAULT
---- a/src/gcc/config/pa/pa.h 2013-02-03 19:52:37.000000000 +0000
-+++ b/src/gcc/config/pa/pa.h 2013-03-20 16:26:18.870235724 +0000
+--- a/src/gcc/config/pa/pa.h
++++ b/src/gcc/config/pa/pa.h
@@ -185,6 +185,20 @@ do { \
builtin_define("_PA_RISC1_0"); \
} while (0)
@@ -200,8 +243,8 @@
/* An old set of OS defines for various BSD-like systems. */
#define TARGET_OS_CPP_BUILTINS() \
do \
---- a/src/gcc/config/rs6000/rs6000.h 2013-02-09 09:30:45.000000000 +0000
-+++ b/src/gcc/config/rs6000/rs6000.h 2013-03-20 16:26:19.058235728 +0000
+--- a/src/gcc/config/rs6000/rs6000.h
++++ b/src/gcc/config/rs6000/rs6000.h
@@ -613,6 +613,28 @@ extern unsigned char rs6000_recip_bits[]
#define TARGET_CPU_CPP_BUILTINS() \
rs6000_cpu_cpp_builtins (pfile)
@@ -231,9 +274,9 @@
/* This is used by rs6000_cpu_cpp_builtins to indicate the byte order
we're compiling for. Some configurations may need to override it. */
#define RS6000_CPU_CPP_ENDIAN_BUILTINS() \
---- a/src/gcc/config/s390/s390.h 2013-03-05 12:02:06.000000000 +0000
-+++ b/src/gcc/config/s390/s390.h 2013-03-20 16:26:19.094235727 +0000
-@@ -108,6 +108,21 @@ enum processor_flags
+--- a/src/gcc/config/s390/s390.h
++++ b/src/gcc/config/s390/s390.h
+@@ -108,6 +108,22 @@ enum processor_flags
} \
while (0)
@@ -250,13 +293,14 @@
+ builtin_define ("D_SoftFloat"); \
+ else if(TARGET_HARD_FLOAT) \
+ builtin_define ("D_HardFloat"); \
++ } \
+ while (0)
+
#ifdef DEFAULT_TARGET_64BIT
#define TARGET_DEFAULT (MASK_64BIT | MASK_ZARCH | MASK_HARD_DFP)
#else
---- a/src/gcc/config/sh/sh.h 2013-03-13 18:09:10.000000000 +0000
-+++ b/src/gcc/config/sh/sh.h 2013-03-20 16:26:19.102235728 +0000
+--- a/src/gcc/config/sh/sh.h
++++ b/src/gcc/config/sh/sh.h
@@ -31,6 +31,22 @@ extern int code_for_indirect_jump_scratc
#define TARGET_CPU_CPP_BUILTINS() sh_cpu_cpp_builtins (pfile)
@@ -280,8 +324,8 @@
/* Value should be nonzero if functions must have frame pointers.
Zero means the frame pointer need not be set up (and parms may be accessed
via the stack pointer) in functions that seem suitable. */
---- a/src/gcc/config/sparc/sparc.h 2013-01-10 20:38:27.000000000 +0000
-+++ b/src/gcc/config/sparc/sparc.h 2013-03-20 16:26:19.110235727 +0000
+--- a/src/gcc/config/sparc/sparc.h
++++ b/src/gcc/config/sparc/sparc.h
@@ -27,6 +27,31 @@ along with GCC; see the file COPYING3.
#define TARGET_CPU_CPP_BUILTINS() sparc_target_macros ()
diff --git a/debian/patches/gdc-versym-os.diff b/debian/patches/gdc-versym-os.diff
index 94e9bce..ae71680 100644
--- a/debian/patches/gdc-versym-os.diff
+++ b/debian/patches/gdc-versym-os.diff
@@ -1,7 +1,39 @@
# DP: Implements D OS version conditions.
---- a/src/gcc/config/arm/linux-eabi.h 2013-01-10 20:38:27.000000000 +0000
-+++ b/src/gcc/config/arm/linux-eabi.h 2013-03-20 16:26:19.134235729 +0000
+This implements the following official versions:
+* Windows
+** Win32
+** Win64
+** Cygwin
+** MinGW
+* linux
+* OSX
+* FreeBSD
+* OpenBSD
+* NetBSD
+* Solaris
+* Posix
+* AIX
+* SysV4
+* Hurd
+* Android
+
+These gdc specific versions are also implemented:
+* GNU_MinGW64 (for mingw-w64)
+* GNU_OpenSolaris (for opensolaris)
+* GNU_GLibc (implemented for linux & bsd & opensolaris)
+* GNU_UCLibc (implemented for linux)
+* GNU_Bionic (implemented for linux)
+
+These official OS versions are not implemented:
+* DragonFlyBSD
+* BSD (other BSDs)
+* Haiku
+* SkyOS
+* SysV3
+
+--- a/src/gcc/config/arm/linux-eabi.h
++++ b/src/gcc/config/arm/linux-eabi.h
@@ -30,6 +30,15 @@
} \
while (false)
@@ -18,8 +50,8 @@
/* We default to a soft-float ABI so that binaries can run on all
target hardware. If you override this to use the hard-float ABI then
change the setting of GLIBC_DYNAMIC_LINKER_DEFAULT as well. */
---- a/src/gcc/config/darwin.h 2013-02-11 23:30:10.000000000 +0000
-+++ b/src/gcc/config/darwin.h 2013-03-20 16:26:19.162235729 +0000
+--- a/src/gcc/config/darwin.h
++++ b/src/gcc/config/darwin.h
@@ -921,4 +921,10 @@ extern void darwin_driver_init (unsigned
providing an osx-version-min of this unless overridden by the User. */
#define DEF_MIN_OSX_VERSION "10.4"
@@ -31,8 +63,8 @@
+ } while (0)
+
#endif /* CONFIG_DARWIN_H */
---- a/src/gcc/config/freebsd.h 2013-01-10 20:38:27.000000000 +0000
-+++ b/src/gcc/config/freebsd.h 2013-03-20 16:26:19.178235729 +0000
+--- a/src/gcc/config/freebsd.h
++++ b/src/gcc/config/freebsd.h
@@ -32,6 +32,13 @@ along with GCC; see the file COPYING3.
#undef TARGET_OS_CPP_BUILTINS
#define TARGET_OS_CPP_BUILTINS() FBSD_TARGET_OS_CPP_BUILTINS()
@@ -47,8 +79,8 @@
#undef CPP_SPEC
#define CPP_SPEC FBSD_CPP_SPEC
---- a/src/gcc/config/gnu.h 2013-02-06 23:12:03.000000000 +0000
-+++ b/src/gcc/config/gnu.h 2013-03-20 16:26:19.182235728 +0000
+--- a/src/gcc/config/gnu.h
++++ b/src/gcc/config/gnu.h
@@ -39,3 +39,11 @@ along with GCC. If not, see <http://www
builtin_assert ("system=unix"); \
builtin_assert ("system=posix"); \
@@ -61,8 +93,8 @@
+ builtin_define ("Hurd"); \
+ builtin_define ("Posix"); \
+ } while (0)
---- a/src/gcc/config/i386/cygwin.h 2013-03-13 15:17:54.000000000 +0000
-+++ b/src/gcc/config/i386/cygwin.h 2013-03-20 16:26:19.190235729 +0000
+--- a/src/gcc/config/i386/cygwin.h
++++ b/src/gcc/config/i386/cygwin.h
@@ -20,6 +20,13 @@ along with GCC; see the file COPYING3.
#define EXTRA_OS_CPP_BUILTINS() /* Nothing. */
@@ -77,8 +109,8 @@
#undef CPP_SPEC
#define CPP_SPEC "%(cpp_cpu) %{posix:-D_POSIX_SOURCE} \
-D__CYGWIN32__ -D__CYGWIN__ %{!ansi:-Dunix} -D__unix__ -D__unix \
---- a/src/gcc/config/i386/linux-common.h 2013-01-10 20:38:27.000000000 +0000
-+++ b/src/gcc/config/i386/linux-common.h 2013-03-20 16:26:19.202235730 +0000
+--- a/src/gcc/config/i386/linux-common.h
++++ b/src/gcc/config/i386/linux-common.h
@@ -27,6 +27,15 @@ along with GCC; see the file COPYING3.
} \
while (0)
@@ -95,8 +127,8 @@
#undef CC1_SPEC
#define CC1_SPEC \
LINUX_OR_ANDROID_CC (GNU_USER_TARGET_CC1_SPEC, \
---- a/src/gcc/config/i386/mingw32.h 2013-01-10 20:38:27.000000000 +0000
-+++ b/src/gcc/config/i386/mingw32.h 2013-03-20 16:26:19.206235730 +0000
+--- a/src/gcc/config/i386/mingw32.h
++++ b/src/gcc/config/i386/mingw32.h
@@ -53,6 +53,18 @@ along with GCC; see the file COPYING3.
} \
while (0)
@@ -116,8 +148,8 @@
#ifndef TARGET_USE_PTHREAD_BY_DEFAULT
#define SPEC_PTHREAD1 "pthread"
#define SPEC_PTHREAD2 "!no-pthread"
---- a/src/gcc/config/i386/mingw-w64.h 2013-01-10 20:38:27.000000000 +0000
-+++ b/src/gcc/config/i386/mingw-w64.h 2013-03-20 16:26:19.206235730 +0000
+--- a/src/gcc/config/i386/mingw-w64.h
++++ b/src/gcc/config/i386/mingw-w64.h
@@ -84,3 +84,10 @@ along with GCC; see the file COPYING3.
%{static:-Bstatic} %{!static:-Bdynamic} \
%{shared|mdll: " SUB_LINK_ENTRY " --enable-auto-image-base} \
@@ -129,8 +161,8 @@
+ TARGET_GENERIC_MINGW_OS_D_BUILTINS(); \
+ builtin_define ("GNU_MinGW64"); \
+ } while (0)
---- a/src/gcc/config/i386/sysv4.h 2013-01-10 20:38:27.000000000 +0000
-+++ b/src/gcc/config/i386/sysv4.h 2013-03-20 16:26:19.210235730 +0000
+--- a/src/gcc/config/i386/sysv4.h
++++ b/src/gcc/config/i386/sysv4.h
@@ -70,3 +70,10 @@ along with GCC; see the file COPYING3.
"|%0,_GLOBAL_OFFSET_TABLE_+(.-.LPR%=)}" \
: "=d"(BASE))
@@ -142,8 +174,8 @@
+ builtin_define ("SysV4"); \
+ builtin_define ("Posix"); \
+ } while (0)
---- a/src/gcc/config/ia64/sysv4.h 2013-01-10 20:38:27.000000000 +0000
-+++ b/src/gcc/config/ia64/sysv4.h 2013-03-20 16:26:19.210235730 +0000
+--- a/src/gcc/config/ia64/sysv4.h
++++ b/src/gcc/config/ia64/sysv4.h
@@ -142,3 +142,10 @@ do { \
#define SDATA_SECTION_ASM_OP "\t.sdata"
@@ -155,8 +187,8 @@
+ builtin_define ("SysV4"); \
+ builtin_define ("Posix"); \
+ } while (0)
---- a/src/gcc/config/kfreebsd-gnu.h 2013-01-10 20:38:27.000000000 +0000
-+++ b/src/gcc/config/kfreebsd-gnu.h 2013-03-20 16:26:19.210235730 +0000
+--- a/src/gcc/config/kfreebsd-gnu.h
++++ b/src/gcc/config/kfreebsd-gnu.h
@@ -29,6 +29,14 @@ along with GCC; see the file COPYING3.
} \
while (0)
@@ -172,8 +204,8 @@
#define GNU_USER_DYNAMIC_LINKER GLIBC_DYNAMIC_LINKER
#define GNU_USER_DYNAMIC_LINKER32 GLIBC_DYNAMIC_LINKER32
#define GNU_USER_DYNAMIC_LINKER64 GLIBC_DYNAMIC_LINKER64
---- a/src/gcc/config/knetbsd-gnu.h 2013-01-10 20:38:27.000000000 +0000
-+++ b/src/gcc/config/knetbsd-gnu.h 2013-03-20 16:26:19.218235730 +0000
+--- a/src/gcc/config/knetbsd-gnu.h
++++ b/src/gcc/config/knetbsd-gnu.h
@@ -30,6 +30,16 @@ along with GCC; see the file COPYING3.
} \
while (0)
@@ -191,8 +223,8 @@
#undef GNU_USER_DYNAMIC_LINKER
#define GNU_USER_DYNAMIC_LINKER "/lib/ld.so.1"
---- a/src/gcc/config/kopensolaris-gnu.h 2013-01-10 20:38:27.000000000 +0000
-+++ b/src/gcc/config/kopensolaris-gnu.h 2013-03-20 16:26:19.218235730 +0000
+--- a/src/gcc/config/kopensolaris-gnu.h
++++ b/src/gcc/config/kopensolaris-gnu.h
@@ -30,5 +30,15 @@ along with GCC; see the file COPYING3.
} \
while (0)
@@ -209,8 +241,8 @@
+
#undef GNU_USER_DYNAMIC_LINKER
#define GNU_USER_DYNAMIC_LINKER "/lib/ld.so.1"
---- a/src/gcc/config/linux-android.h 2013-01-10 20:38:27.000000000 +0000
-+++ b/src/gcc/config/linux-android.h 2013-03-20 16:26:19.218235730 +0000
+--- a/src/gcc/config/linux-android.h
++++ b/src/gcc/config/linux-android.h
@@ -25,6 +25,12 @@
builtin_define ("__ANDROID__"); \
} while (0)
@@ -224,8 +256,8 @@
#if ANDROID_DEFAULT
# define NOANDROID "mno-android"
#else
---- a/src/gcc/config/linux.h 2013-01-10 20:38:27.000000000 +0000
-+++ b/src/gcc/config/linux.h 2013-03-20 16:26:19.226235729 +0000
+--- a/src/gcc/config/linux.h
++++ b/src/gcc/config/linux.h
@@ -49,6 +49,20 @@ see the files COPYING3 and COPYING.RUNTI
builtin_assert ("system=posix"); \
} while (0)
@@ -247,8 +279,8 @@
/* Determine which dynamic linker to use depending on whether GLIBC or
uClibc or Bionic is the default C library and whether
-muclibc or -mglibc or -mbionic has been passed to change the default. */
---- a/src/gcc/config/mips/linux-common.h 2013-01-10 20:38:27.000000000 +0000
-+++ b/src/gcc/config/mips/linux-common.h 2013-03-20 16:26:19.230235729 +0000
+--- a/src/gcc/config/mips/linux-common.h
++++ b/src/gcc/config/mips/linux-common.h
@@ -27,6 +27,15 @@ along with GCC; see the file COPYING3.
ANDROID_TARGET_OS_CPP_BUILTINS(); \
} while (0)
@@ -265,8 +297,8 @@
#undef LINK_SPEC
#define LINK_SPEC \
LINUX_OR_ANDROID_LD (GNU_USER_TARGET_LINK_SPEC, \
---- a/src/gcc/config/netbsd.h 2013-01-10 20:38:27.000000000 +0000
-+++ b/src/gcc/config/netbsd.h 2013-03-20 16:26:19.230235729 +0000
+--- a/src/gcc/config/netbsd.h
++++ b/src/gcc/config/netbsd.h
@@ -29,6 +29,14 @@ along with GCC; see the file COPYING3.
} \
while (0)
@@ -282,8 +314,8 @@
/* CPP_SPEC parts common to all NetBSD targets. */
#define NETBSD_CPP_SPEC \
"%{posix:-D_POSIX_SOURCE} \
---- a/src/gcc/config/openbsd.h 2013-01-10 20:38:27.000000000 +0000
-+++ b/src/gcc/config/openbsd.h 2013-03-20 16:26:19.230235729 +0000
+--- a/src/gcc/config/openbsd.h
++++ b/src/gcc/config/openbsd.h
@@ -84,6 +84,14 @@ along with GCC; see the file COPYING3.
} \
while (0)
@@ -299,8 +331,8 @@
/* TARGET_OS_CPP_BUILTINS() common to all OpenBSD ELF targets. */
#define OPENBSD_OS_CPP_BUILTINS_ELF() \
do \
---- a/src/gcc/config/rs6000/aix.h 2013-01-10 20:38:27.000000000 +0000
-+++ b/src/gcc/config/rs6000/aix.h 2013-03-20 16:26:19.230235729 +0000
+--- a/src/gcc/config/rs6000/aix.h
++++ b/src/gcc/config/rs6000/aix.h
@@ -110,6 +110,13 @@
} \
while (0)
@@ -315,8 +347,8 @@
/* Define appropriate architecture macros for preprocessor depending on
target switches. */
---- a/src/gcc/config/rs6000/sysv4.h 2013-01-10 20:38:27.000000000 +0000
-+++ b/src/gcc/config/rs6000/sysv4.h 2013-03-20 16:26:19.238235730 +0000
+--- a/src/gcc/config/rs6000/sysv4.h
++++ b/src/gcc/config/rs6000/sysv4.h
@@ -523,6 +523,13 @@ extern int fixuplabelno;
while (0)
#endif
@@ -331,8 +363,8 @@
#undef ASM_SPEC
#define ASM_SPEC "%(asm_cpu) \
%{,assembler|,assembler-with-cpp: %{mregnames} %{mno-regnames}} \
---- a/src/gcc/config/sparc/sysv4.h 2013-01-10 20:38:27.000000000 +0000
-+++ b/src/gcc/config/sparc/sysv4.h 2013-03-20 16:26:19.242235729 +0000
+--- a/src/gcc/config/sparc/sysv4.h
++++ b/src/gcc/config/sparc/sysv4.h
@@ -117,3 +117,10 @@ do { ASM_OUTPUT_ALIGN ((FILE), Pmode ==
#undef MCOUNT_FUNCTION