summaryrefslogtreecommitdiff
path: root/debian/patches/rename-info-files.diff
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/rename-info-files.diff')
-rw-r--r--debian/patches/rename-info-files.diff68
1 files changed, 37 insertions, 31 deletions
diff --git a/debian/patches/rename-info-files.diff b/debian/patches/rename-info-files.diff
index 6415496..9518269 100644
--- a/debian/patches/rename-info-files.diff
+++ b/debian/patches/rename-info-files.diff
@@ -48,7 +48,7 @@ Index: b/src/gcc/fortran/Make-lang.in
===================================================================
--- a/src/gcc/fortran/Make-lang.in
+++ b/src/gcc/fortran/Make-lang.in
-@@ -119,7 +119,8 @@
+@@ -117,7 +117,8 @@
cd $(srcdir)/fortran; etags -o TAGS.sub *.c *.h; \
etags --include TAGS.sub --include ../TAGS.sub
@@ -58,7 +58,7 @@ Index: b/src/gcc/fortran/Make-lang.in
fortran.dvi: doc/gfortran.dvi doc/gfc-internals.dvi
F95_HTMLFILES = $(build_htmldir)/gfortran
-@@ -191,10 +192,10 @@
+@@ -189,10 +190,10 @@
$(srcdir)/doc/include/gcc-common.texi \
gcc-vers.texi
@@ -71,7 +71,7 @@ Index: b/src/gcc/fortran/Make-lang.in
-o $@ $<; \
else true; fi
-@@ -262,7 +263,7 @@
+@@ -260,7 +261,7 @@
fortran.install-plugin:
@@ -80,7 +80,7 @@ Index: b/src/gcc/fortran/Make-lang.in
fortran.install-man: $(DESTDIR)$(man1dir)/$(GFORTRAN_INSTALL_NAME)$(man1ext)
-@@ -280,7 +281,7 @@
+@@ -278,7 +279,7 @@
rm -rf $(DESTDIR)$(bindir)/$(GFORTRAN_INSTALL_NAME)$(exeext); \
rm -rf $(DESTDIR)$(man1dir)/$(GFORTRAN_INSTALL_NAME)$(man1ext); \
rm -rf $(DESTDIR)$(bindir)/$(GFORTRAN_TARGET_INSTALL_NAME)$(exeext); \
@@ -93,7 +93,7 @@ Index: b/src/gcc/Makefile.in
===================================================================
--- a/src/gcc/Makefile.in
+++ b/src/gcc/Makefile.in
-@@ -4242,8 +4242,29 @@
+@@ -4266,8 +4266,29 @@
doc: $(BUILD_INFO) $(GENERATED_MANPAGES)
@@ -125,7 +125,7 @@ Index: b/src/gcc/Makefile.in
info: $(INFOFILES) lang.info @GENINSRC@ srcinfo lang.srcinfo
-@@ -4302,21 +4321,41 @@
+@@ -4321,21 +4342,41 @@
# patterns. To use them, put each of the specific targets with its
# specific dependencies but no build commands.
@@ -174,7 +174,7 @@ Index: b/src/gcc/Makefile.in
-I $(gcc_docdir)/include -o $@ $<; \
fi
-@@ -4682,11 +4721,11 @@
+@@ -4701,11 +4742,11 @@
# $(INSTALL_DATA) might be a relative pathname, so we can't cd into srcdir
# to do the install.
install-info:: doc installdirs \
@@ -191,7 +191,7 @@ Index: b/src/gcc/Makefile.in
lang.install-info
$(DESTDIR)$(infodir)/%.info: doc/%.info installdirs
-@@ -4893,8 +4932,11 @@
+@@ -4912,8 +4953,11 @@
-rm -rf $(DESTDIR)$(bindir)/$(GCOV_INSTALL_NAME)$(exeext)
-rm -rf $(DESTDIR)$(man1dir)/$(GCC_INSTALL_NAME)$(man1ext)
-rm -rf $(DESTDIR)$(man1dir)/cpp$(man1ext)
@@ -257,7 +257,7 @@ Index: b/src/gcc/java/Make-lang.in
===================================================================
--- a/src/gcc/java/Make-lang.in
+++ b/src/gcc/java/Make-lang.in
-@@ -127,9 +127,10 @@
+@@ -126,9 +126,10 @@
etags --include TAGS.sub --include ../TAGS.sub
@@ -270,7 +270,7 @@ Index: b/src/gcc/java/Make-lang.in
-cp -p $^ $(srcdir)/doc
java.dvi: doc/gcj.dvi
-@@ -195,7 +196,7 @@
+@@ -194,7 +195,7 @@
-rm -rf $(DESTDIR)$(man1dir)/aot-compile$(man1ext)
-rm -rf $(DESTDIR)$(man1dir)/rebuild-gcj-db$(man1ext)
@@ -279,7 +279,7 @@ Index: b/src/gcc/java/Make-lang.in
java.install-pdf: $(JAVA_PDFFILES)
@$(NORMAL_INSTALL)
-@@ -340,10 +341,10 @@
+@@ -339,10 +340,10 @@
gcc-vers.texi
# Documentation
@@ -323,7 +323,7 @@ Index: b/src/gcc/doc/invoke.texi
===================================================================
--- a/src/gcc/doc/invoke.texi
+++ b/src/gcc/doc/invoke.texi
-@@ -9851,7 +9851,7 @@
+@@ -9884,7 +9884,7 @@
@option{-nodefaultlibs} is @file{libgcc.a}, a library of internal subroutines
which GCC uses to overcome shortcomings of particular machines, or special
needs for some languages.
@@ -332,7 +332,7 @@ Index: b/src/gcc/doc/invoke.texi
Collection (GCC) Internals},
for more discussion of @file{libgcc.a}.)
In most cases, you need @file{libgcc.a} even when you want to avoid
-@@ -9860,7 +9860,7 @@
+@@ -9893,7 +9893,7 @@
This ensures that you have no unresolved references to internal GCC
library subroutines.
(An example of such an internal subroutine is @samp{__main}, used to ensure C++
@@ -341,7 +341,7 @@ Index: b/src/gcc/doc/invoke.texi
GNU Compiler Collection (GCC) Internals}.)
@item -pie
-@@ -20527,7 +20527,7 @@
+@@ -20720,7 +20720,7 @@
@option{-B}, @option{-I} and @option{-L} (@pxref{Directory Options}). These
take precedence over places specified using environment variables, which
in turn take precedence over those specified by the configuration of GCC@.
@@ -350,7 +350,7 @@ Index: b/src/gcc/doc/invoke.texi
GNU Compiler Collection (GCC) Internals}.
@table @env
-@@ -20687,7 +20687,7 @@
+@@ -20880,7 +20880,7 @@
A precompiled header file is searched for when @code{#include} is
seen in the compilation. As it searches for the included file
@@ -363,7 +363,7 @@ Index: b/src/gcc/doc/extend.texi
===================================================================
--- a/src/gcc/doc/extend.texi
+++ b/src/gcc/doc/extend.texi
-@@ -15129,7 +15129,7 @@
+@@ -15212,7 +15212,7 @@
test for the GNU compiler the same way as for C programs: check for a
predefined macro @code{__GNUC__}. You can also use @code{__GNUG__} to
test specifically for GNU C++ (@pxref{Common Predefined Macros,,
@@ -376,7 +376,7 @@ Index: b/src/gcc/doc/standards.texi
===================================================================
--- a/src/gcc/doc/standards.texi
+++ b/src/gcc/doc/standards.texi
-@@ -295,8 +295,8 @@
+@@ -294,8 +294,8 @@
GNAT Reference Manual}, for information on standard
conformance and compatibility of the Ada compiler.
@@ -391,7 +391,7 @@ Index: b/src/gcc/doc/libgcc.texi
===================================================================
--- a/src/gcc/doc/libgcc.texi
+++ b/src/gcc/doc/libgcc.texi
-@@ -25,7 +25,7 @@
+@@ -24,7 +24,7 @@
GCC will also generate calls to C library routines, such as
@code{memcpy} and @code{memset}, in some cases. The set of routines
that GCC may possibly use is documented in @ref{Other
@@ -404,7 +404,7 @@ Index: b/src/gcc/doc/gccint.texi
===================================================================
--- a/src/gcc/doc/gccint.texi
+++ b/src/gcc/doc/gccint.texi
-@@ -51,7 +51,7 @@
+@@ -49,7 +49,7 @@
@ifnottex
@dircategory Software development
@direntry
@@ -413,7 +413,7 @@ Index: b/src/gcc/doc/gccint.texi
@end direntry
This file documents the internals of the GNU compilers.
@sp 1
-@@ -83,7 +83,7 @@
+@@ -81,7 +81,7 @@
@value{VERSION_PACKAGE}
@end ifset
version @value{version-GCC}. The use of the GNU compilers is documented in a
@@ -426,7 +426,7 @@ Index: b/src/gcc/doc/cpp.texi
===================================================================
--- a/src/gcc/doc/cpp.texi
+++ b/src/gcc/doc/cpp.texi
-@@ -53,7 +53,7 @@
+@@ -50,7 +50,7 @@
@ifinfo
@dircategory Software development
@direntry
@@ -439,7 +439,7 @@ Index: b/src/gcc/doc/passes.texi
===================================================================
--- a/src/gcc/doc/passes.texi
+++ b/src/gcc/doc/passes.texi
-@@ -199,7 +199,7 @@
+@@ -197,7 +197,7 @@
@item Mudflap declaration registration
If mudflap (@pxref{Optimize Options,,-fmudflap -fmudflapth
@@ -452,7 +452,7 @@ Index: b/src/gcc/doc/gcc.texi
===================================================================
--- a/src/gcc/doc/gcc.texi
+++ b/src/gcc/doc/gcc.texi
-@@ -65,9 +65,9 @@
+@@ -63,9 +63,9 @@
@ifnottex
@dircategory Software development
@direntry
@@ -465,7 +465,7 @@ Index: b/src/gcc/doc/gcc.texi
@end direntry
This file documents the use of the GNU compilers.
@sp 1
-@@ -127,7 +127,7 @@
+@@ -125,7 +125,7 @@
The internals of the GNU compilers, including how to port them to new
targets and some information about how to write front ends for new
languages, are documented in a separate manual. @xref{Top,,
@@ -478,7 +478,7 @@ Index: b/src/gcc/doc/makefile.texi
===================================================================
--- a/src/gcc/doc/makefile.texi
+++ b/src/gcc/doc/makefile.texi
-@@ -140,7 +140,7 @@
+@@ -139,7 +139,7 @@
Builds a compiler with profiling feedback information. In this case,
the second and third stages are named @samp{profile} and @samp{feedback},
respectively. For more information, see
@@ -491,7 +491,7 @@ Index: b/src/gcc/doc/install.texi
===================================================================
--- a/src/gcc/doc/install.texi
+++ b/src/gcc/doc/install.texi
-@@ -98,7 +98,7 @@
+@@ -94,7 +94,7 @@
@end ifinfo
@dircategory Software development
@direntry
@@ -675,7 +675,7 @@ Index: b/src/gcc/go/Make-lang.in
-I $(gcc_docdir)/include -o $@ $<; \
else true; fi
-@@ -118,7 +118,7 @@
+@@ -117,7 +118,7 @@
go.all.cross: gccgo-cross$(exeext)
go.start.encap: gccgo$(exeext)
go.rest.encap:
@@ -724,6 +724,8 @@ Index: b/src/gcc/go/gccgo.texi
only documents the options specific to @command{gccgo}.
The @command{gccgo} command may be used to compile Go source code into
+Index: b/src/libquadmath/libquadmath.texi
+===================================================================
--- a/src/libquadmath/libquadmath.texi
+++ b/src/libquadmath/libquadmath.texi
@@ -25,7 +25,7 @@
@@ -735,9 +737,11 @@ Index: b/src/gcc/go/gccgo.texi
@end direntry
This manual documents the GCC Quad-Precision Math Library API.
+Index: b/src/libquadmath/Makefile.am
+===================================================================
--- a/src/libquadmath/Makefile.am
+++ b/src/libquadmath/Makefile.am
-@@ -129,22 +129,24 @@
+@@ -132,22 +132,24 @@
all-local: $(STAMP_GENINSRC)
@@ -768,9 +772,11 @@ Index: b/src/gcc/go/gccgo.texi
# Automake Documentation:
+Index: b/src/libquadmath/Makefile.in
+===================================================================
--- a/src/libquadmath/Makefile.in
+++ b/src/libquadmath/Makefile.in
-@@ -164,7 +164,8 @@
+@@ -169,7 +169,8 @@
MULTISUBDIR =
MULTIDO = true
MULTICLEAN = true
@@ -780,7 +786,7 @@ Index: b/src/gcc/go/gccgo.texi
am__TEXINFO_TEX_DIR = $(srcdir)/../gcc/doc/include
DVIS = libquadmath.dvi
PDFS = libquadmath.pdf
-@@ -397,8 +398,8 @@
+@@ -405,8 +406,8 @@
# AM_CONDITIONAL on configure check ACX_CHECK_PROG_VER([MAKEINFO])
@BUILD_INFO_TRUE@@BUILD_LIBQUADMATH_TRUE@STAMP_BUILD_INFO = stamp-build-info
@@ -791,7 +797,7 @@ Index: b/src/gcc/go/gccgo.texi
# Automake Documentation:
# If your package has Texinfo files in many directories, you can use the
-@@ -1412,17 +1413,17 @@
+@@ -1464,17 +1465,17 @@
@BUILD_LIBQUADMATH_TRUE@all-local: $(STAMP_GENINSRC)