summaryrefslogtreecommitdiff
path: root/debian/rules.conf
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules.conf')
-rw-r--r--debian/rules.conf5
1 files changed, 5 insertions, 0 deletions
diff --git a/debian/rules.conf b/debian/rules.conf
index 1b59492..c106b6d 100644
--- a/debian/rules.conf
+++ b/debian/rules.conf
@@ -176,6 +176,10 @@ ifeq ($(multiarch_stage1),yes)
endif
DPKG_BUILD_DEP = dpkg-dev (>= $(DPKGV)),
+ifeq ($(DEB_HOST_ARCH),$(DEB_TARGET_ARCH))
+ TARGET_QUAL = :$(DEB_TARGET_ARCH)
+endif
+
# The binutils version needed.
# The oldest suitable versions for the various platforms can be found in
# INSTALL/specific.html ; we take a tighter dependency if possible to be on
@@ -1186,6 +1190,7 @@ versioned-files:
-e 's/@java_priority@/$(java_priority)/g' \
-e 's/@gcc_priority@/$(subst .,,$(BASE_VERSION))/g' \
-e 's/@TARGET@/$(DEB_TARGET_GNU_TYPE)/g' \
+ -e 's/@TARGET_QUAL@/$(TARGET_QUAL)/g' \
$$f > $$f2; \
touch -r $$f $$f2; \
done