summaryrefslogtreecommitdiff
path: root/debian/rules.conf
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules.conf')
-rw-r--r--debian/rules.conf8
1 files changed, 8 insertions, 0 deletions
diff --git a/debian/rules.conf b/debian/rules.conf
index 7f8d5f7..1b59492 100644
--- a/debian/rules.conf
+++ b/debian/rules.conf
@@ -379,6 +379,13 @@ endif
AUTO_BUILD_DEP := m4, libtool,
AUTO_BUILD_DEP += autoconf2.64,
+# ensure that the common libs, built from the next GCC version are available
+ifeq ($(PKGSOURCE),gcc-$(BASE_VERSION))
+ ifneq ($(with_common_libs),yes)
+ BASE_BUILD_DEP = gcc-4.9-base,
+ endif
+endif
+
ifneq ($(DEB_CROSS),yes)
JAVA_BUILD_DEP := zlib1g-dev, libantlr-java, python, libffi-dev,
@@ -578,6 +585,7 @@ ctrl_flags += \
-DLIBC_BIARCH_BUILD_DEP="$(LIBC_BIARCH_BUILD_DEP)" \
-DLIBC_DBG_DEP="$(LIBC_DBG_DEP)" \
-DFORTRAN_BUILD_DEP="$(FORTRAN_BUILD_DEP)" \
+ -DBASE_BUILD_DEP="$(BASE_BUILD_DEP)" \
-DGNAT_BUILD_DEP="$(GNAT_BUILD_DEP)" \
-DJAVA_BUILD_DEP="$(JAVA_BUILD_DEP)" \
-DGO_BUILD_DEP="$(GO_BUILD_DEP)" \