summaryrefslogtreecommitdiff
path: root/debian/rules.conf
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules.conf')
-rw-r--r--debian/rules.conf5
1 files changed, 5 insertions, 0 deletions
diff --git a/debian/rules.conf b/debian/rules.conf
index dff7d21..52e8765 100644
--- a/debian/rules.conf
+++ b/debian/rules.conf
@@ -310,6 +310,10 @@ else
endif
endif
+# needed for the include/asm symlink to run the testsuite for
+# non default multilibs
+GCC_MULTILIB_BUILD_DEP = g++-multilib [$(multilib_archs)],
+
LIBUNWIND_DEV_DEP := libunwind7-dev$(LS)$(AQ) (>= 0.98.5-6)
LIBUNWIND_BUILD_DEP := $(LIBUNWIND_DEV_DEP) [ia64],
LIBATOMIC_OPS_BUILD_DEP := libatomic-ops-dev$(LS) [ia64],
@@ -565,6 +569,7 @@ ctrl_flags += \
-DDPKG_BUILD_DEP="$(DPKG_BUILD_DEP)" \
-DSOURCE_BUILD_DEP="$(SOURCE_BUILD_DEP)" \
-DCROSS_BUILD_DEP="$(CROSS_BUILD_DEP)" \
+ -DGCC_MULTILIB_BUILD_DEP='$(GCC_MULTILIB_BUILD_DEP)' \
-DMULTILIB_ARCHS="$(multilib_archs)" \
-DNEON_ARCHS="$(neon_archs)" \
-DTP=$(TP) \