summaryrefslogtreecommitdiff
path: root/debian/rules.conf
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules.conf')
-rw-r--r--debian/rules.conf9
1 files changed, 9 insertions, 0 deletions
diff --git a/debian/rules.conf b/debian/rules.conf
index 2d43fc0..65f8f7d 100644
--- a/debian/rules.conf
+++ b/debian/rules.conf
@@ -1048,6 +1048,15 @@ ifeq ($(DEB_CROSS),yes)
echo 'dep:gdccross=gdc$(pkg_ver) (>= $(DEB_GCC_SOFT_VERSION))' \
>> debian/substvars.local.tmp
endif
+ifeq ($(with_libphobos),yes)
+ ifeq ($(DEB_CROSS),yes)
+ echo 'dep:gdccross=gdc$(pkg_ver) (>= $(DEB_GCC_SOFT_VERSION))' \
+ >> debian/substvars.local.tmp
+ else
+ echo 'dep:phobosdev=libphobos$(pkg_ver)-dev (>= $(DEB_GCC_SOFT_VERSION))' \
+ >> debian/substvars.local.tmp
+ endif
+endif
#ifneq (,$(findstring gtk, $(java_awt_peers)))
# echo 'pkg:gcjgtk=libgcj$(subst 0,,$(GCJ_SONAME))-awt-gtk (>= $(DEB_GCJ_VERSION))' \
# >> debian/substvars.local.tmp