summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/patches/testsuite-hardening-ssp.diff31
-rw-r--r--debian/rules.patch1
2 files changed, 0 insertions, 32 deletions
diff --git a/debian/patches/testsuite-hardening-ssp.diff b/debian/patches/testsuite-hardening-ssp.diff
deleted file mode 100644
index 491f636..0000000
--- a/debian/patches/testsuite-hardening-ssp.diff
+++ /dev/null
@@ -1,31 +0,0 @@
-# DP: Build some test cases with -fno-stack-protector, which fail with stack protector enabled.
-
---- a/src/gcc/testsuite/gcc.dg/superblock.c
-+++ b/src/gcc/testsuite/gcc.dg/superblock.c
-@@ -1,5 +1,5 @@
- /* { dg-do compile } */
--/* { dg-options "-O2 -fno-asynchronous-unwind-tables -fsched2-use-superblocks -fdump-rtl-sched2 -fdump-rtl-bbro" } */
-+/* { dg-options "-O2 -fno-asynchronous-unwind-tables -fsched2-use-superblocks -fdump-rtl-sched2 -fdump-rtl-bbro -fno-stack-protector" } */
-
- typedef int aligned __attribute__ ((aligned (64)));
- extern void abort (void);
---- a/src/gcc/testsuite/gcc.dg/stack-usage-1.c
-+++ b/src/gcc/testsuite/gcc.dg/stack-usage-1.c
-@@ -1,5 +1,5 @@
- /* { dg-do compile } */
--/* { dg-options "-fstack-usage" } */
-+/* { dg-options "-fstack-usage -fno-stack-protector" } */
-
- /* This is aimed at testing basic support for -fstack-usage in the back-ends.
- See the SPARC back-end for example (grep flag_stack_usage_info in sparc.c).
---- a/src/gcc/testsuite/g++.dg/asan/asan_test.C
-+++ b/src/gcc/testsuite/g++.dg/asan/asan_test.C
-@@ -2,7 +2,7 @@
- // { dg-skip-if "" { *-*-* } { "*" } { "-O2" } }
- // { dg-skip-if "" { *-*-* } { "-flto" } { "" } }
- // { dg-additional-sources "asan_globals_test-wrapper.cc" }
--// { dg-options "-fsanitize=address -fno-builtin -Wall -Wno-format -Werror -g -DASAN_UAR=0 -DASAN_HAS_EXCEPTIONS=1 -DASAN_HAS_BLACKLIST=0 -DASAN_USE_DEJAGNU_GTEST=1 -lasan -lpthread -ldl" }
-+// { dg-options "-fsanitize=address -fno-stack-protector -fno-builtin -Wall -Wno-format -Werror -g -DASAN_UAR=0 -DASAN_HAS_EXCEPTIONS=1 -DASAN_HAS_BLACKLIST=0 -DASAN_USE_DEJAGNU_GTEST=1 -lasan -lpthread -ldl" }
- // { dg-additional-options "-DASAN_NEEDS_SEGV=1" { target { ! arm*-*-* } } }
- // { dg-additional-options "-DASAN_LOW_MEMORY=1 -DASAN_NEEDS_SEGV=0" { target arm*-*-* } }
- // { dg-additional-options "-DASAN_AVOID_EXPENSIVE_TESTS=1" { target { ! run_expensive_tests } } }
diff --git a/debian/rules.patch b/debian/rules.patch
index d3f1c72..8b87c53 100644
--- a/debian/rules.patch
+++ b/debian/rules.patch
@@ -92,7 +92,6 @@ debian_patches += \
pr61106 \
pr61126 \
pr57653 \
- testsuite-hardening-ssp \
libitm-aarch64 \
# FIXME: still necessary for cross building the native compiler?