summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authordoko <doko@6ca36cf4-e1d1-0310-8c6f-e303bb2178ca>2014-06-04 11:10:53 +0000
committerdoko <doko@6ca36cf4-e1d1-0310-8c6f-e303bb2178ca>2014-06-04 11:10:53 +0000
commit3c812d01481f7d84cc8c29f6eac1511a4dccd7fe (patch)
tree53bf944c002263a3ece457beb52185e791d4d3b3 /debian
parent6783aca6eddea7b37165b22058ba1d78373c9284 (diff)
downloadgcc-49-3c812d01481f7d84cc8c29f6eac1511a4dccd7fe.tar.gz
* Fix installation of gcc-{ar,nm,ranlib} man pages for snapshot builds.
Closes: #745906. git-svn-id: svn://svn.debian.org/svn/gcccvs/branches/sid/gcc-4.9@7434 6ca36cf4-e1d1-0310-8c6f-e303bb2178ca
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog2
-rw-r--r--debian/rules29
2 files changed, 10 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index b64e113..eb5fe62 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -8,6 +8,8 @@ gcc-4.9 (4.9.0-6) UNRELEASED; urgency=medium
* Fix the removal of the libstdc++6 package, removing byte-compiled pretty
printer files and pycache directories.
* Fix PR c++/61046, taken from the trunk. LP: #1313102.
+ * Fix installation of gcc-{ar,nm,ranlib} man pages for snapshot builds.
+ Closes: #745906.
-- Matthias Klose <doko@debian.org> Fri, 30 May 2014 15:34:10 +0200
diff --git a/debian/rules2 b/debian/rules2
index d868aa0..d71d221 100644
--- a/debian/rules2
+++ b/debian/rules2
@@ -1928,7 +1928,8 @@ ifeq ($(with_hppa64),yes)
fi
for i in ar nm ranlib; do \
- cp debian/gcc-$$i$(pkg_ver).1 $(d)/$(PF)/share/man/man1/$(cmd_prefix)gcc-$$i$(pkg_ver).1; \
+ cp debian/gcc-$$i-$(BASE_VERSION).1 \
+ $(d)/$(PF)/share/man/man1/hppa64-linux-gnu-gcc-$$i.1; \
done
: # remove files not needed from the hppa64 build
@@ -1967,6 +1968,12 @@ endif
install
ls -l $(d)/$(PF)/bin
+
+ for i in ar nm ranlib; do \
+ cp debian/gcc-$$i-$(BASE_VERSION).1 \
+ $(d)/$(PF)/share/man/man1/$(cmd_prefix)gcc-$$i.1; \
+ done
+
if [ ! -x $(d)/$(PF)/bin/$(TARGET_ALIAS)-gcc ]; then \
mv $(d)/$(PF)/bin/$(TARGET_ALIAS)-gcc-4* $(d)/$(PF)/bin/$(TARGET_ALIAS)-gcc; \
else \