summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authordoko <doko@6ca36cf4-e1d1-0310-8c6f-e303bb2178ca>2014-04-02 11:08:18 +0000
committerdoko <doko@6ca36cf4-e1d1-0310-8c6f-e303bb2178ca>2014-04-02 11:08:18 +0000
commit6eb4ce5b32c64a36c95e3f0ceaf803c863dfb07d (patch)
tree3825c1cdfe96f2313c8445cff998cf2cfc755be2 /debian
parente2721b61c5348f9347bf6e792be181944b3c2bab (diff)
downloadgcc-49-6eb4ce5b32c64a36c95e3f0ceaf803c863dfb07d.tar.gz
* Fix PR target/60034 (AArch64), taken from the trunk. LP: #1270789.
git-svn-id: svn://svn.debian.org/svn/gcccvs/branches/sid/gcc-4.8@7249 6ca36cf4-e1d1-0310-8c6f-e303bb2178ca
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog1
-rw-r--r--debian/patches/pr60034.diff42
-rw-r--r--debian/rules.patch1
3 files changed, 44 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 73a6101..3720fa1 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -4,6 +4,7 @@ gcc-4.8 (4.8.2-19) UNRELEASED; urgency=medium
gcc-4.8 package.
* Explicitly configure with --disable-multilib on sparc64 when no
multilibs are requested (Helmut Grohne). Closes: #743342.
+ * Fix PR target/60034 (AArch64), taken from the trunk. LP: #1270789.
-- Matthias Klose <doko@debian.org> Tue, 01 Apr 2014 22:57:44 +0200
diff --git a/debian/patches/pr60034.diff b/debian/patches/pr60034.diff
new file mode 100644
index 0000000..86ba3b2
--- /dev/null
+++ b/debian/patches/pr60034.diff
@@ -0,0 +1,42 @@
+# DP: Fix PR target/60034 (AArch64), taken from the trunk.
+
+gcc/
+
+2014-03-31 Kugan Vivekanandarajah <kuganv@linaro.org>
+
+ PR target/60034
+ * aarch64/aarch64.c (aarch64_classify_address): Fix alignment for
+ section anchor.
+
+gcc/testsuite/
+
+2014-03-31 Kugan Vivekanandarajah <kuganv@linaro.org>
+
+ PR target/60034
+ * gcc.target/aarch64/pr60034.c: New file.
+
+--- a/src/gcc/testsuite/gcc.target/aarch64/pr60034.c
++++ b/src/gcc/testsuite/gcc.target/aarch64/pr60034.c
+@@ -0,0 +1,10 @@
++/* { dg-do compile } */
++/* { dg-options "-std=gnu99 -O" } */
++
++static unsigned long global_max_fast;
++
++void __libc_mallopt (int param_number, int value)
++{
++ __asm__ __volatile__ ("# %[_SDT_A21]" :: [_SDT_A21] "nor" ((global_max_fast)));
++ global_max_fast = 1;
++}
+--- a/src/gcc/config/aarch64/aarch64.c
++++ b/src/gcc/config/aarch64/aarch64.c
+@@ -3196,6 +3196,9 @@
+ }
+ else if (SYMBOL_REF_DECL (sym))
+ align = DECL_ALIGN (SYMBOL_REF_DECL (sym));
++ else if (SYMBOL_REF_HAS_BLOCK_INFO_P (sym)
++ && SYMBOL_REF_BLOCK (sym) != NULL)
++ align = SYMBOL_REF_BLOCK (sym)->alignment;
+ else
+ align = BITS_PER_UNIT;
+
diff --git a/debian/rules.patch b/debian/rules.patch
index 40d24ab..9e99d23 100644
--- a/debian/rules.patch
+++ b/debian/rules.patch
@@ -91,6 +91,7 @@ debian_patches += \
$(if $(with_linaro_branch),aarch64-abi-fix) \
fix-ffi_call_VFP-with-no-VFP-argument \
pr58595 \
+ $(if $(with_linaro_branch),pr60034) \
gdb_depends := $(shell dpkg -s gdb | grep '^Depends:.*libpython3')
ifneq (,$(findstring libpython3,$(gdb_depends)))