summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authordoko <doko@6ca36cf4-e1d1-0310-8c6f-e303bb2178ca>2014-05-18 13:57:57 +0000
committerdoko <doko@6ca36cf4-e1d1-0310-8c6f-e303bb2178ca>2014-05-18 13:57:57 +0000
commite308b107a7670069b9171e44b6e3da2805be4ff3 (patch)
tree5faced5db57b1965b3990c2f2c6a6d2ca7a6f676 /debian
parent9bd7bf4b64f55e61f95c97f5232dea03ffd9247d (diff)
downloadgcc-49-e308b107a7670069b9171e44b6e3da2805be4ff3.tar.gz
* Apply the proposed patch for PR c/57653. Closes: #734345.
git-svn-id: svn://svn.debian.org/svn/gcccvs/branches/sid/gcc-4.9@7384 6ca36cf4-e1d1-0310-8c6f-e303bb2178ca
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog3
-rw-r--r--debian/patches/pr57653.diff17
-rw-r--r--debian/rules.patch1
3 files changed, 20 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 18f2244..54a3686 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,4 +1,4 @@
-gcc-4.9 (4.9.0-4) UNRELEASED; urgency=medium
+gcc-4.9 (4.9.0-4) unstable; urgency=medium
* Update to SVN 20140518 (r210581) from the gcc-4_9-branch.
* Update the local ada-libgnatprj patch for AArch64. Addresses: #748233.
@@ -6,6 +6,7 @@ gcc-4.9 (4.9.0-4) UNRELEASED; urgency=medium
* Build-depend on systemtap-sdt-dev, on every architecure, doesn't seem to hurt
on architectures where it is not supported. Closes: #748315.
* Update the gcc-default-format-security patch (Steve Beattie). LP: #1317305.
+ * Apply the proposed patch for PR c/57653. Closes: #734345.
-- Matthias Klose <doko@debian.org> Sun, 18 May 2014 14:02:40 +0200
diff --git a/debian/patches/pr57653.diff b/debian/patches/pr57653.diff
new file mode 100644
index 0000000..ea42013
--- /dev/null
+++ b/debian/patches/pr57653.diff
@@ -0,0 +1,17 @@
+# DP: Proposed patch for PR c/57653.
+
+Index: b/src/gcc/c-family/c-opts.c
+===================================================================
+--- a/src/gcc/c-family/c-opts.c
++++ b/src/gcc/c-family/c-opts.c
+@@ -1363,6 +1363,10 @@ c_finish_options (void)
+ static void
+ push_command_line_include (void)
+ {
++ // This can happen if disabled by -imacros for example.
++ if (include_cursor > deferred_count)
++ return;
++
+ if (!done_preinclude)
+ {
+ done_preinclude = true;
diff --git a/debian/rules.patch b/debian/rules.patch
index 0aa6f5b..51acb40 100644
--- a/debian/rules.patch
+++ b/debian/rules.patch
@@ -78,6 +78,7 @@ debian_patches += \
libffi-m68k \
libitm-no-fortify-source \
pr59758 \
+ pr57653 \
gdb_depends := $(shell dpkg -s gdb | grep '^Depends:.*libpython3')
ifneq (,$(findstring libpython3,$(gdb_depends)))