summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authordoko <doko@6ca36cf4-e1d1-0310-8c6f-e303bb2178ca>2014-03-29 15:55:47 +0000
committerdoko <doko@6ca36cf4-e1d1-0310-8c6f-e303bb2178ca>2014-03-29 15:55:47 +0000
commite39b767c23afef608227860a76d97ef9ee90116c (patch)
tree7ca87bb4fdb16618dd2c92e44d863430fdccb28e /debian
parent241a76c9b564fc3902ca2a55c95a1de7ad05381c (diff)
downloadgcc-49-e39b767c23afef608227860a76d97ef9ee90116c.tar.gz
* Update to SVN 20140329 (r208938) from the gcc-4_8-branch.
git-svn-id: svn://svn.debian.org/svn/gcccvs/branches/sid/gcc-4.8@7240 6ca36cf4-e1d1-0310-8c6f-e303bb2178ca
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog4
-rw-r--r--debian/patches/svn-updates.diff146
2 files changed, 125 insertions, 25 deletions
diff --git a/debian/changelog b/debian/changelog
index 3a9d0b1..b3078b8 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,13 +1,13 @@
gcc-4.8 (4.8.2-18) UNRELEASED; urgency=medium
- * Update to SVN 20140327 (r208877) from the gcc-4_8-branch.
+ * Update to SVN 20140329 (r208938) from the gcc-4_8-branch.
* Don't ignore DEB_CROSS_NO_BIARCH=yes ignored for DEB_TARGET_ARCH=x32.
(Helmut Grohne). Closes: #742358.
* debian/patches/ada-ppc64.diff: Fix for ppc64el (Ulrich Weigand).
* Avoid clobbering stack pointer via P8 fusion peephole. fixing Ada build
on ppc64el (Ulrich Weigand).
- -- Matthias Klose <doko@debian.org> Sun, 23 Mar 2014 10:48:18 +0100
+ -- Matthias Klose <doko@debian.org> Sat, 29 Mar 2014 16:33:31 +0100
gcc-4.8 (4.8.2-17) unstable; urgency=medium
diff --git a/debian/patches/svn-updates.diff b/debian/patches/svn-updates.diff
index 91c3745..abfd7a4 100644
--- a/debian/patches/svn-updates.diff
+++ b/debian/patches/svn-updates.diff
@@ -1,10 +1,10 @@
-# DP: updates from the 4.8 branch upto 20140327 (r208877).
+# DP: updates from the 4.8 branch upto 20140329 (r208938).
last_updated()
{
cat > ${dir}LAST_UPDATED <<EOF
-Thu Mar 27 22:09:00 CET 2014
-Thu Mar 27 21:09:00 UTC 2014 (revision 208877)
+Sat Mar 29 16:27:26 CET 2014
+Sat Mar 29 15:27:26 UTC 2014 (revision 208938)
EOF
}
@@ -6540,7 +6540,7 @@ Index: gcc/DATESTAMP
+++ b/src/gcc/DATESTAMP (.../branches/gcc-4_8-branch)
@@ -1 +1 @@
-20131016
-+20140327
++20140329
Index: gcc/value-prof.c
===================================================================
--- a/src/gcc/value-prof.c (.../tags/gcc_4_8_2_release)
@@ -13495,6 +13495,29 @@ Index: gcc/testsuite/gfortran.dg/proc_ptr_comp_38.f90
+ procedure(real), pointer, nopass :: f1, f2
+ end type
+ end
+Index: gcc/testsuite/gfortran.dg/where_4.f90
+===================================================================
+--- a/src/gcc/testsuite/gfortran.dg/where_4.f90 (.../tags/gcc_4_8_2_release)
++++ b/src/gcc/testsuite/gfortran.dg/where_4.f90 (.../branches/gcc-4_8-branch)
+@@ -0,0 +1,18 @@
++! { dg-do compile }
++! PR 60522 - this used to ICE.
++! Original test case Roger Ferrer Ibanez
++subroutine foo(a, b)
++ implicit none
++ integer, dimension(:), intent(inout) :: a
++ integer, dimension(:), intent(in) :: b
++
++ where (b(:) > 0)
++ where (b(:) > 100)
++ a(lbound(a, 1):ubound(a, 1)) = b(lbound(b, 1):ubound(b, 1)) * b(lbound(b, 1):ubound(b, 1)) - 100
++ elsewhere
++ a(lbound(a, 1):ubound(a, 1)) = b(lbound(b, 1):ubound(b, 1)) * b(lbound(b, 1):ubound(b, 1))
++ end where
++ elsewhere
++ a(lbound(a, 1):ubound(a, 1)) = - b(lbound(b, 1):ubound(b, 1)) * b(lbound(b, 1):ubound(b, 1))
++ end where
++end subroutine foo
Index: gcc/testsuite/gfortran.dg/gomp/pr59467.f90
===================================================================
--- a/src/gcc/testsuite/gfortran.dg/gomp/pr59467.f90 (.../tags/gcc_4_8_2_release)
@@ -16868,7 +16891,12 @@ Index: gcc/testsuite/ChangeLog
===================================================================
--- a/src/gcc/testsuite/ChangeLog (.../tags/gcc_4_8_2_release)
+++ b/src/gcc/testsuite/ChangeLog (.../branches/gcc-4_8-branch)
-@@ -1,3 +1,1045 @@
+@@ -1,3 +1,1050 @@
++2014-04-28 Thomas Koenig <tkoenig@gcc.gnu.org>
++
++ PR fortran/60522
++ * gfortran.dg/where_4.f90: New test case.
++
+2014-03-26 Martin Jambor <mjambor@suse.cz>
+
+ PR ipa/60419
@@ -17914,7 +17942,7 @@ Index: gcc/testsuite/ChangeLog
2013-10-16 Release Manager
* GCC 4.8.2 released.
-@@ -39,9 +1081,9 @@
+@@ -39,9 +1086,9 @@
Backport from mainline
2013-06-27 Andreas Krebbel <Andreas.Krebbel@de.ibm.com>
@@ -17927,7 +17955,7 @@ Index: gcc/testsuite/ChangeLog
2013-10-04 Tobias Burnus <burnus@net-b.de>
-@@ -307,8 +1349,8 @@
+@@ -307,8 +1354,8 @@
Backport from mainline
2013-08-12 Perez Read <netfirewall@gmail.com>
@@ -17938,7 +17966,7 @@ Index: gcc/testsuite/ChangeLog
2013-08-11 Janus Weil <janus@gcc.gnu.org>
-@@ -494,7 +1536,7 @@
+@@ -494,7 +1541,7 @@
2013-06-19 Wei Mi <wmi@google.com>
PR rtl-optimization/57518
@@ -17947,7 +17975,7 @@ Index: gcc/testsuite/ChangeLog
2013-06-11 Tobias Burnus <burnus@net-b.de>
-@@ -623,8 +1665,8 @@
+@@ -623,8 +1670,8 @@
2013-05-09 Martin Jambor <mjambor@suse.cz>
@@ -17958,7 +17986,7 @@ Index: gcc/testsuite/ChangeLog
2013-05-08 Marc Glisse <marc.glisse@inria.fr>
-@@ -701,7 +1743,7 @@
+@@ -701,7 +1748,7 @@
2013-04-25 Marek Polacek <polacek@redhat.com>
PR tree-optimization/57066
@@ -17967,7 +17995,7 @@ Index: gcc/testsuite/ChangeLog
2013-05-02 Jakub Jelinek <jakub@redhat.com>
-@@ -727,8 +1769,8 @@
+@@ -727,8 +1774,8 @@
Backport from mainline
2013-04-24 Vladimir Makarov <vmakarov@redhat.com>
@@ -17978,7 +18006,7 @@ Index: gcc/testsuite/ChangeLog
2013-05-02 Vladimir Makarov <vmakarov@redhat.com>
-@@ -735,8 +1777,8 @@
+@@ -735,8 +1782,8 @@
Backport from mainline
2013-04-22 Vladimir Makarov <vmakarov@redhat.com>
@@ -17989,7 +18017,7 @@ Index: gcc/testsuite/ChangeLog
2013-05-02 Vladimir Makarov <vmakarov@redhat.com>
-@@ -743,8 +1785,8 @@
+@@ -743,8 +1790,8 @@
Backport from mainline
2013-04-18 Jakub Jelinek <jakub@redhat.com>
@@ -18000,7 +18028,7 @@ Index: gcc/testsuite/ChangeLog
2013-05-02 Vladimir Makarov <vmakarov@redhat.com>
-@@ -751,8 +1793,8 @@
+@@ -751,8 +1798,8 @@
Backport from mainline
2013-04-19 Vladimir Makarov <vmakarov@redhat.com>
@@ -18011,7 +18039,7 @@ Index: gcc/testsuite/ChangeLog
2013-05-02 Ian Bolton <ian.bolton@arm.com>
-@@ -1102,7 +2144,7 @@
+@@ -1102,7 +2149,7 @@
2013-03-29 Tobias Burnus <burnus@net-b.de>
PR fortran/56737
@@ -18020,7 +18048,7 @@ Index: gcc/testsuite/ChangeLog
2013-04-02 Richard Biener <rguenther@suse.de>
-@@ -1636,7 +2678,7 @@
+@@ -1636,7 +2683,7 @@
2013-02-20 Jan Hubicka <jh@suse.cz>
PR tree-optimization/56265
@@ -18029,7 +18057,7 @@ Index: gcc/testsuite/ChangeLog
2013-02-20 Richard Biener <rguenther@suse.de>
-@@ -1823,11 +2865,9 @@
+@@ -1823,11 +2870,9 @@
Avoid instrumenting duplicated memory access in the same basic block
* c-c++-common/asan/no-redundant-instrumentation-1.c: New test.
@@ -24307,7 +24335,20 @@ Index: gcc/fortran/trans-expr.c
===================================================================
--- a/src/gcc/fortran/trans-expr.c (.../tags/gcc_4_8_2_release)
+++ b/src/gcc/fortran/trans-expr.c (.../branches/gcc-4_8-branch)
-@@ -670,7 +670,6 @@
+@@ -355,7 +355,11 @@
+ gfc_conv_expr_descriptor (parmse, e);
+
+ if (e->rank != class_ts.u.derived->components->as->rank)
+- class_array_data_assign (&block, ctree, parmse->expr, true);
++ {
++ gcc_assert (class_ts.u.derived->components->as->type
++ == AS_ASSUMED_RANK);
++ class_array_data_assign (&block, ctree, parmse->expr, false);
++ }
+ else
+ {
+ if (gfc_expr_attr (e).codimension)
+@@ -670,7 +674,6 @@
gfc_add_modify (&parmse->post, vptr,
fold_convert (TREE_TYPE (vptr), ctree));
@@ -24315,7 +24356,7 @@ Index: gcc/fortran/trans-expr.c
if (optional)
{
tree tmp2;
-@@ -6343,7 +6342,13 @@
+@@ -6343,7 +6346,13 @@
/* Returns a reference to the scalar evaluated outside the loop
for this case. */
gfc_conv_expr (se, expr);
@@ -24558,7 +24599,26 @@ Index: gcc/fortran/ChangeLog
===================================================================
--- a/src/gcc/fortran/ChangeLog (.../tags/gcc_4_8_2_release)
+++ b/src/gcc/fortran/ChangeLog (.../branches/gcc-4_8-branch)
-@@ -1,3 +1,227 @@
+@@ -1,3 +1,246 @@
++2014-03-29 Mikael Morin <mikael@gcc.gnu.org>
++
++ PR fortran/60677
++ * trans-intrinsic.c (gfc_conv_intrinsic_ichar): Enlarge argument
++ list buffer.
++
++2014-03-28 Mikael Morin <mikael@gcc.gnu.org>
++ Tobias Burnus <burnus@net-b.de>
++
++ PR fortran/60576
++ * trans-expr.c (gfc_conv_derived_to_class): Avoid
++ generation of out-of-bounds range expr.
++
++2014-03-28 Thomas Koenig <tkoenig@gcc.gnu.org>
++
++ PR fortran/60522
++ * frontend-passes.c (cfe_code): Do not walk subtrees
++ for WHERE.
++
+2014-03-20 Tobias Burnus <burnus@net-b.de>
+
+ PR fortran/60543
@@ -25197,7 +25257,45 @@ Index: gcc/fortran/frontend-passes.c
===================================================================
--- a/src/gcc/fortran/frontend-passes.c (.../tags/gcc_4_8_2_release)
+++ b/src/gcc/fortran/frontend-passes.c (.../branches/gcc-4_8-branch)
-@@ -1214,7 +1214,9 @@
+@@ -623,12 +623,35 @@
+ to insert statements as needed. */
+
+ static int
+-cfe_code (gfc_code **c, int *walk_subtrees ATTRIBUTE_UNUSED,
+- void *data ATTRIBUTE_UNUSED)
++cfe_code (gfc_code **c, int *walk_subtrees, void *data ATTRIBUTE_UNUSED)
+ {
+ current_code = c;
+ inserted_block = NULL;
+ changed_statement = NULL;
++
++ /* Do not do anything inside a WHERE statement; scalar assignments, BLOCKs
++ and allocation on assigment are prohibited inside WHERE, and finally
++ masking an expression would lead to wrong-code when replacing
++
++ WHERE (a>0)
++ b = sum(foo(a) + foo(a))
++ END WHERE
++
++ with
++
++ WHERE (a > 0)
++ tmp = foo(a)
++ b = sum(tmp + tmp)
++ END WHERE
++*/
++
++ if ((*c)->op == EXEC_WHERE)
++ {
++ *walk_subtrees = 0;
++ return 0;
++ }
++
++
+ return 0;
+ }
+
+@@ -1214,7 +1237,9 @@
/* Replace A // B < A // C with B < C, and A // B < C // B
with A < C. */
if (op1->ts.type == BT_CHARACTER && op2->ts.type == BT_CHARACTER
@@ -25688,10 +25786,12 @@ Index: gcc/fortran/trans-intrinsic.c
===================================================================
--- a/src/gcc/fortran/trans-intrinsic.c (.../tags/gcc_4_8_2_release)
+++ b/src/gcc/fortran/trans-intrinsic.c (.../branches/gcc-4_8-branch)
-@@ -4685,8 +4685,10 @@
+@@ -4684,9 +4684,11 @@
+ static void
gfc_conv_intrinsic_ichar (gfc_se * se, gfc_expr * expr)
{
- tree args[2], type, pchartype;
+- tree args[2], type, pchartype;
++ tree args[3], type, pchartype;
+ int nargs;
- gfc_conv_intrinsic_function_args (se, expr, args, 2);