summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authordoko <doko@6ca36cf4-e1d1-0310-8c6f-e303bb2178ca>2014-06-24 22:18:19 +0000
committerdoko <doko@6ca36cf4-e1d1-0310-8c6f-e303bb2178ca>2014-06-24 22:18:19 +0000
commitea67d8f061b875e72efd58ae5b4cd453cf6f9c22 (patch)
treeca73d96d2ea60d2514a83bf77636add4492c0a14 /debian
parent91f641176d16f7aa31e8a0e6a225a298e5dafffd (diff)
downloadgcc-49-ea67d8f061b875e72efd58ae5b4cd453cf6f9c22.tar.gz
* Fix removal of python byte-code files in libstdc++6. Closes: #751435.
git-svn-id: svn://svn.debian.org/svn/gcccvs/branches/sid/gcc-4.9@7469 6ca36cf4-e1d1-0310-8c6f-e303bb2178ca
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog1
-rw-r--r--debian/libstdc++CXX.prerm4
-rw-r--r--debian/rules.conf5
3 files changed, 8 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index ad9d4b8..108b607 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -11,6 +11,7 @@ gcc-4.9 (4.9.0-8) unstable; urgency=medium
* Update libstdc++ and libvtv symbols files for builds configured with
--enable-vtable-verify.
* Remove version requirement for dependency on make. Closes: #751891.
+ * Fix removal of python byte-code files in libstdc++6. Closes: #751435.
-- Matthias Klose <doko@debian.org> Tue, 24 Jun 2014 12:26:30 +0200
diff --git a/debian/libstdc++CXX.prerm b/debian/libstdc++CXX.prerm
index 2b0ae23..34b9d91 100644
--- a/debian/libstdc++CXX.prerm
+++ b/debian/libstdc++CXX.prerm
@@ -4,9 +4,9 @@ set -e
case "$1" in
remove)
- files=$(dpkg -L libstdc++@CXX@ | awk -F/ 'BEGIN {OFS="/"} /\.py$/ {$NF=sprintf("__pycache__/%s.*.py[co]", substr($NF,1,length($NF)-3)); print}')
+ files=$(dpkg -L libstdc++@CXX@@TARGET_QUAL@ | awk -F/ 'BEGIN {OFS="/"} /\.py$/ {$NF=sprintf("__pycache__/%s.*.py[co]", substr($NF,1,length($NF)-3)); print}')
rm -f $files
- dirs=$(dpkg -L libstdc++@CXX@ | awk -F/ 'BEGIN {OFS="/"} /\.py$/ {NF--; print}' | sort -u)
+ dirs=$(dpkg -L libstdc++@CXX@@TARGET_QUAL@ | awk -F/ 'BEGIN {OFS="/"} /\.py$/ {NF--; print}' | sort -u)
find $dirs -mindepth 1 -maxdepth 1 -name __pycache__ -type d -empty | xargs -r rmdir
esac
diff --git a/debian/rules.conf b/debian/rules.conf
index eaf2ffa..d335d8e 100644
--- a/debian/rules.conf
+++ b/debian/rules.conf
@@ -178,6 +178,10 @@ ifeq ($(multiarch_stage1),yes)
endif
DPKG_BUILD_DEP = dpkg-dev (>= $(DPKGV)),
+ifeq ($(DEB_HOST_ARCH),$(DEB_TARGET_ARCH))
+ TARGET_QUAL = :$(DEB_TARGET_ARCH)
+endif
+
# The binutils version needed.
# The oldest suitable versions for the various platforms can be found in
# INSTALL/specific.html ; we take a tighter dependency if possible to be on
@@ -1248,6 +1252,7 @@ versioned-files:
-e 's/@java_priority@/$(java_priority)/g' \
-e 's/@gcc_priority@/$(subst .,,$(BASE_VERSION))/g' \
-e 's/@TARGET@/$(DEB_TARGET_GNU_TYPE)/g' \
+ -e 's/@TARGET_QUAL@/$(TARGET_QUAL)/g' \
$$f > $$f2; \
touch -r $$f $$f2; \
done