summaryrefslogtreecommitdiff
path: root/debian/rules.conf
diff options
context:
space:
mode:
authordoko <doko@6ca36cf4-e1d1-0310-8c6f-e303bb2178ca>2015-03-27 19:47:42 +0000
committerdoko <doko@6ca36cf4-e1d1-0310-8c6f-e303bb2178ca>2015-03-27 19:47:42 +0000
commit37f4a936ab25c869e5e97dae36b770e42318fa0a (patch)
treea559501889bb31f26e54a35e53d4f4e0726789c2 /debian/rules.conf
parentb0130bb43f521f1374d5f29ee1c871e71c88d820 (diff)
downloadgcc-5-37f4a936ab25c869e5e97dae36b770e42318fa0a.tar.gz
* gnat related work (partly based on #780640):
- Update patches for GCC 5. - Build the gnat packages from the gcc-5 source package. - Don't build a gnat-base package from the gcc-5 source. - Stop building the gnat-5-sjlj package for now, patch needs an update. - Fix the packaging when not building the gnat-5-sjlj package. - Don't apply the ada-symbolic-tracebacks, patch needs an update. - Fix the libgnatprj build, build with -DIN_GCC. git-svn-id: svn://anonscm.debian.org/gcccvs/branches/sid/gcc-5@7922 6ca36cf4-e1d1-0310-8c6f-e303bb2178ca
Diffstat (limited to 'debian/rules.conf')
-rw-r--r--debian/rules.conf9
1 files changed, 6 insertions, 3 deletions
diff --git a/debian/rules.conf b/debian/rules.conf
index af2c7db..66d581a 100644
--- a/debian/rules.conf
+++ b/debian/rules.conf
@@ -486,7 +486,7 @@ ifeq ($(PKGSOURCE),gcc-$(BASE_VERSION))
# Build gnat as part of the combiled gcc-x.y source package. Do not fail
# if gnat is not present on unsupported architectures; the build scripts
# will not use gnat anyway.
- GNAT_BUILD_DEP := gnat-5 [$(ada_no_archs)],
+ GNAT_BUILD_DEP := gnat-4.9 [$(ada_no_archs)],
endif
else ifeq ($(single_package),yes)
# Ditto, as part of the gcc-snapshot package.
@@ -804,6 +804,9 @@ endif
languages += ada
addons += libgnat libs source # libgmath libnof lib64gnat ssp
+ ifeq ($(with_gnatsjlj),yes)
+ addons += adasjlj
+ endif
languages += java
addons += gcj
@@ -888,11 +891,11 @@ endif
ifeq ($(with_separate_gnat),yes)
ifeq ($(PKGSOURCE),gcc-$(BASE_VERSION))
languages := $(filter-out ada,$(languages))
- addons := $(filter-out libgnat,$(addons))
+ addons := $(filter-out libgnat adasjlj,$(addons))
endif
ifeq ($(PKGSOURCE),gnat-$(BASE_VERSION))
languages = ada
- addons = libgnat
+ addons = gnatbase libgnat
endif
endif
ifeq ($(with_separate_gdc),yes)