summaryrefslogtreecommitdiff
path: root/debian/rules.d/binary-go.mk
diff options
context:
space:
mode:
authordoko <doko@6ca36cf4-e1d1-0310-8c6f-e303bb2178ca>2015-02-28 17:47:55 +0000
committerdoko <doko@6ca36cf4-e1d1-0310-8c6f-e303bb2178ca>2015-02-28 17:47:55 +0000
commit7cf18136336acd03836afe5c464c88f998be49d1 (patch)
tree696c398cdb1ff42e122746d54e03c2ff7f7c6971 /debian/rules.d/binary-go.mk
parent1cb8e2a88087a440e9d0f3eb220e2712b6c6a265 (diff)
downloadgcc-5-7cf18136336acd03836afe5c464c88f998be49d1.tar.gz
* Don't strip the libgo library, or some things won't work as documented,
like runtime.Callers. Still keep the -dbg packages and check if some debug information can be stripped. git-svn-id: svn://anonscm.debian.org/gcccvs/branches/sid/gcc-5@7865 6ca36cf4-e1d1-0310-8c6f-e303bb2178ca
Diffstat (limited to 'debian/rules.d/binary-go.mk')
-rw-r--r--debian/rules.d/binary-go.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/debian/rules.d/binary-go.mk b/debian/rules.d/binary-go.mk
index ff78dfa..36ae6f0 100644
--- a/debian/rules.d/binary-go.mk
+++ b/debian/rules.d/binary-go.mk
@@ -102,7 +102,8 @@ define __do_gccgo
debian/dh_doclink -p$(p_l) $(p_base)
debian/dh_doclink -p$(p_d) $(p_base)
- dh_strip -p$(p_l) --dbg-package=$(p_d)
+ : # don't strip: https://gcc.gnu.org/ml/gcc-patches/2015-02/msg01722.html
+ : # dh_strip -p$(p_l) --dbg-package=$(p_d)
dh_compress -p$(p_l) -p$(p_d)
dh_fixperms -p$(p_l) -p$(p_d)
$(cross_makeshlibs) dh_makeshlibs -p$(p_l)