summaryrefslogtreecommitdiff
path: root/debian/rules.defs
diff options
context:
space:
mode:
authordoko <doko@6ca36cf4-e1d1-0310-8c6f-e303bb2178ca>2015-03-21 20:06:12 +0000
committerdoko <doko@6ca36cf4-e1d1-0310-8c6f-e303bb2178ca>2015-03-21 20:06:12 +0000
commit8b20ca261fbe37d0ffdde3e4acc0cbf28f000c84 (patch)
tree34afdd9acbc8f2d414690d47101a5c7156b5656b /debian/rules.defs
parent1bb19ea2354f3e60c2387adff99ad3c448c5543c (diff)
downloadgcc-5-8b20ca261fbe37d0ffdde3e4acc0cbf28f000c84.tar.gz
* Update libcc1 build support.
git-svn-id: svn://anonscm.debian.org/gcccvs/branches/sid/gcc-5@7901 6ca36cf4-e1d1-0310-8c6f-e303bb2178ca
Diffstat (limited to 'debian/rules.defs')
-rw-r--r--debian/rules.defs10
1 files changed, 10 insertions, 0 deletions
diff --git a/debian/rules.defs b/debian/rules.defs
index 77f0139..c2aa735 100644
--- a/debian/rules.defs
+++ b/debian/rules.defs
@@ -521,6 +521,14 @@ ifeq (,$(findstring gcc-,$(PKGSOURCE)))
with_jit :=
endif
+with_cc1 := yes
+with_cc1 := $(call envfilt, cc1, , , $(with_cc1))
+ifeq ($(with_cc1),yes)
+ ifneq ($(DEB_CROSS),yes)
+ with_libcc1 := yes
+ endif
+endif
+
# Build all packages needed for C development
ifneq ($(with_base_only),yes)
ifeq ($(with_dev),yes)
@@ -573,6 +581,8 @@ ifeq ($(with_ada)-$(with_separate_gnat),yes-yes)
with_mudflap := no
with_gccbase := no
with_cdev := no
+ with_cc1 := no
+ with_libcc1 := no
else
debian_extra_langs += ada
with_ada := built from separate source