summaryrefslogtreecommitdiff
path: root/debian/rules.defs
diff options
context:
space:
mode:
authordoko <doko@6ca36cf4-e1d1-0310-8c6f-e303bb2178ca>2015-05-09 17:20:12 +0000
committerdoko <doko@6ca36cf4-e1d1-0310-8c6f-e303bb2178ca>2015-05-09 17:20:12 +0000
commita7b37c34ff099b29ff70964fc2ec03dbbd2f4098 (patch)
treee03342183e794e1e166b3f769a2955c08fe9cb7f /debian/rules.defs
parent956643732ab4648e4fd078120d6d60c4b99731fa (diff)
downloadgcc-5-a7b37c34ff099b29ff70964fc2ec03dbbd2f4098.tar.gz
* Update to SVN 20150507 (r222873, 5.1.1) from the gcc-5-branch.
* Fix gotools configury. * Configure with --disable-libstdcxx-dual-abi --with-default-libstdcxx-abi=c++98 While libstdc++ provides a dual ABI to support both the c++98 and c++11 ABI, there is no committment on compatibility of the old experimental c++11 ABI from GCC 4.9 and the stable c++11 ABI in GCC 5. Closes: #784655. git-svn-id: svn://anonscm.debian.org/gcccvs/branches/sid/gcc-5@8031 6ca36cf4-e1d1-0310-8c6f-e303bb2178ca
Diffstat (limited to 'debian/rules.defs')
-rw-r--r--debian/rules.defs6
1 files changed, 5 insertions, 1 deletions
diff --git a/debian/rules.defs b/debian/rules.defs
index 1d014e5..49923e3 100644
--- a/debian/rules.defs
+++ b/debian/rules.defs
@@ -527,6 +527,10 @@ ifeq (,$(findstring gcc-,$(PKGSOURCE)))
with_jit :=
endif
+ifneq (,$(findstring build-cross, $(build_type)))
+ with_jit := disabled for cross builds
+endif
+
with_cc1 := yes
with_cc1 := $(call envfilt, cc1, , , $(with_cc1))
ifeq ($(with_cc1),yes)
@@ -653,7 +657,7 @@ ifneq (,$(filter $(distrelease),squeeze wheezy jessie sid lucid precise trusty u
libstdcxx_abi = c++98
endif
# FIXME later ... sid is still known as jessie
-libstdcxx_abi = c++11
+libstdcxx_abi = c++98
# Build all packages needed for C++ development
ifeq ($(with_cxx),yes)