summaryrefslogtreecommitdiff
path: root/debian/patches/ada-kfreebsd.diff
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/ada-kfreebsd.diff')
-rw-r--r--debian/patches/ada-kfreebsd.diff24
1 files changed, 12 insertions, 12 deletions
diff --git a/debian/patches/ada-kfreebsd.diff b/debian/patches/ada-kfreebsd.diff
index dbabf5d..a7afd80 100644
--- a/debian/patches/ada-kfreebsd.diff
+++ b/debian/patches/ada-kfreebsd.diff
@@ -4,7 +4,7 @@ Index: b/src/gcc/ada/terminals.c
===================================================================
--- a/src/gcc/ada/terminals.c
+++ b/src/gcc/ada/terminals.c
-@@ -987,6 +987,7 @@
+@@ -1071,6 +1071,7 @@ __gnat_setup_winsize (void *desc, int ro
/* On some system termio is either absent or including it will disable termios
(HP-UX) */
#if ! defined (__hpux__) && ! defined (FREEBSD) && \
@@ -179,7 +179,7 @@ Index: b/src/gcc/ada/gcc-interface/Makefile.in
===================================================================
--- a/src/gcc/ada/gcc-interface/Makefile.in
+++ b/src/gcc/ada/gcc-interface/Makefile.in
-@@ -1272,7 +1272,7 @@
+@@ -1361,7 +1361,7 @@ ifeq ($(strip $(filter-out %86 kfreebsd%
a-intnam.ads<a-intnam-freebsd.ads \
s-inmaop.adb<s-inmaop-posix.adb \
s-intman.adb<s-intman-posix.adb \
@@ -188,7 +188,7 @@ Index: b/src/gcc/ada/gcc-interface/Makefile.in
s-osinte.ads<s-osinte-kfreebsd-gnu.ads \
s-osprim.adb<s-osprim-posix.adb \
s-taprop.adb<s-taprop-posix.adb \
-@@ -1330,7 +1330,7 @@
+@@ -1421,7 +1421,7 @@ ifeq ($(strip $(filter-out x86_64 kfreeb
a-numaux.ads<a-numaux-x86.ads \
s-inmaop.adb<s-inmaop-posix.adb \
s-intman.adb<s-intman-posix.adb \
@@ -201,7 +201,7 @@ Index: b/src/gcc/ada/s-osinte-kfreebsd-gnu.ads
===================================================================
--- a/src/gcc/ada/s-osinte-kfreebsd-gnu.ads
+++ b/src/gcc/ada/s-osinte-kfreebsd-gnu.ads
-@@ -45,6 +45,7 @@
+@@ -45,6 +45,7 @@ package System.OS_Interface is
pragma Preelaborate;
pragma Linker_Options ("-lpthread");
@@ -209,7 +209,7 @@ Index: b/src/gcc/ada/s-osinte-kfreebsd-gnu.ads
subtype int is Interfaces.C.int;
subtype char is Interfaces.C.char;
-@@ -206,9 +207,7 @@
+@@ -206,9 +207,7 @@ package System.OS_Interface is
function nanosleep (rqtp, rmtp : access timespec) return int;
pragma Import (C, nanosleep, "nanosleep");
@@ -220,7 +220,7 @@ Index: b/src/gcc/ada/s-osinte-kfreebsd-gnu.ads
function clock_gettime
(clock_id : clockid_t;
-@@ -252,6 +251,16 @@
+@@ -252,6 +251,16 @@ package System.OS_Interface is
function getpid return pid_t;
pragma Import (C, getpid, "getpid");
@@ -237,7 +237,7 @@ Index: b/src/gcc/ada/s-osinte-kfreebsd-gnu.ads
-------------
-- Threads --
-------------
-@@ -282,6 +291,14 @@
+@@ -282,6 +291,14 @@ package System.OS_Interface is
PTHREAD_SCOPE_PROCESS : constant := 0;
PTHREAD_SCOPE_SYSTEM : constant := 2;
@@ -252,7 +252,7 @@ Index: b/src/gcc/ada/s-osinte-kfreebsd-gnu.ads
-----------
-- Stack --
-----------
-@@ -419,31 +436,25 @@
+@@ -419,31 +436,25 @@ package System.OS_Interface is
PTHREAD_PRIO_PROTECT : constant := 2;
PTHREAD_PRIO_INHERIT : constant := 1;
@@ -288,7 +288,7 @@ Index: b/src/gcc/ada/s-osinte-kfreebsd-gnu.ads
type struct_sched_param is record
sched_priority : int; -- scheduling priority
-@@ -570,8 +581,8 @@
+@@ -570,8 +581,8 @@ private
-- #define sa_handler __sigaction_u._handler
-- #define sa_sigaction __sigaction_u._sigaction
@@ -299,7 +299,7 @@ Index: b/src/gcc/ada/s-osinte-kfreebsd-gnu.ads
-- sigcontext type is opaque, so it is architecturally neutral.
-- It is always passed as an access type, so define it as an empty record
-- since the contents are not used anywhere.
-@@ -588,9 +599,6 @@
+@@ -588,9 +599,6 @@ private
end record;
pragma Convention (C, timespec);
@@ -313,7 +313,7 @@ Index: b/src/gcc/ada/gsocket.h
===================================================================
--- a/src/gcc/ada/gsocket.h
+++ b/src/gcc/ada/gsocket.h
-@@ -231,7 +231,7 @@
+@@ -241,7 +241,7 @@
# endif
#endif
@@ -326,7 +326,7 @@ Index: b/src/gcc/ada/s-oscons-tmplt.c
===================================================================
--- a/src/gcc/ada/s-oscons-tmplt.c
+++ b/src/gcc/ada/s-oscons-tmplt.c
-@@ -1420,7 +1420,7 @@
+@@ -1446,7 +1446,7 @@ CND(CLOCK_FASTEST, "Fastest clock")
#endif
CND(CLOCK_THREAD_CPUTIME_ID, "Thread CPU clock")