summaryrefslogtreecommitdiff
path: root/debian/patches/illumos-rdynamic.diff
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/illumos-rdynamic.diff')
-rw-r--r--debian/patches/illumos-rdynamic.diff29
1 files changed, 29 insertions, 0 deletions
diff --git a/debian/patches/illumos-rdynamic.diff b/debian/patches/illumos-rdynamic.diff
new file mode 100644
index 0000000..2e3b83c
--- /dev/null
+++ b/debian/patches/illumos-rdynamic.diff
@@ -0,0 +1,29 @@
+Index: gcc-48/src/gcc/configure.ac
+===================================================================
+--- gcc-48.orig/src/gcc/configure.ac 2014-04-18 19:40:11.321832341 +0400
++++ gcc-48/src/gcc/configure.ac 2014-04-18 19:51:39.967711188 +0400
+@@ -5230,15 +5230,21 @@
+ : # No need to use a flag
+ AC_MSG_RESULT([yes])
+ else
+- AC_MSG_RESULT([yes])
+ AC_MSG_CHECKING([for -rdynamic])
+ ${CC} ${CFLAGS} ${LDFLAGS} -rdynamic conftest.c -o conftest$ac_exeext > /dev/null 2>&1
+ if $export_sym_check conftest$ac_exeext | grep -q foobar > /dev/null; then
+ plugin_rdynamic=yes
+ pluginlibs="-rdynamic"
+ else
+- plugin_rdynamic=no
+- enable_plugin=no
++ AC_MSG_CHECKING([for -Wl,-export-dynamic])
++ ${CC} ${CFLAGS} ${LDFLAGS} -Wl,-export-dynamic conftest.c -o conftest > /dev/null 2>&1
++ if $export_sym_check conftest | grep foobar > /dev/null; then
++ plugin_rdynamic=yes
++ pluginlibs="-Wl,-export-dynamic"
++ else
++ plugin_rdynamic=no
++ enable_plugin=no
++ fi
+ fi
+ AC_MSG_RESULT([$plugin_rdynamic])
+ fi