summaryrefslogtreecommitdiff
path: root/debian/rules2
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules2')
-rw-r--r--debian/rules218
1 files changed, 10 insertions, 8 deletions
diff --git a/debian/rules2 b/debian/rules2
index ddddf76..efec45d 100644
--- a/debian/rules2
+++ b/debian/rules2
@@ -585,21 +585,23 @@ ifneq (,$(filter $(DEB_TARGET_ARCH), amd64 i386 hurd-i386 kfreebsd-i386 kfreebsd
endif
ifneq (,$(findstring mips-linux,$(DEB_TARGET_GNU_TYPE)))
- CONFARGS += --with-arch-32=mips2 --with-tune-32=mips32 --with-fp-32=xx
+ CONFARGS += --with-mips-plt
+ CONFARGS += --with-arch-32=mips32r2 --with-fp-32=xx
ifeq ($(multilib),yes)
ifeq ($(biarchn32)-$(biarch64),yes-yes)
CONFARGS += --enable-targets=all
- CONFARGS += --with-arch-64=mips3 --with-tune-64=mips64
+ CONFARGS += --with-arch-64=mips64r2
endif
endif
endif
ifneq (,$(findstring mipsel-linux,$(DEB_TARGET_GNU_TYPE)))
- CONFARGS += --with-arch-32=mips2 --with-tune-32=mips32 --with-fp-32=xx
+ CONFARGS += --with-mips-plt
+ CONFARGS += --with-arch-32=mips2 --with-tune-32=mips32r2 --with-fp-32=xx
ifeq ($(multilib),yes)
ifeq ($(biarchn32)-$(biarch64),yes-yes)
CONFARGS += --enable-targets=all
- CONFARGS += --with-arch-64=mips3 --with-tune-64=mips64
+ CONFARGS += --with-arch-64=mips3 --with-tune-64=mips64r2
endif
endif
endif
@@ -629,22 +631,22 @@ endif
ifneq (,$(findstring mips64el-linux-gnuabi64,$(DEB_TARGET_GNU_TYPE)))
CONFARGS += --with-mips-plt
- CONFARGS += --with-arch-64=mips64 --with-tune-64=mips64r2
+ CONFARGS += --with-arch-64=mips64r2
ifeq ($(multilib),yes)
ifeq ($(biarchn32)-$(biarch32),yes-yes)
CONFARGS += --enable-targets=all
- CONFARGS += --with-arch-32=mips2 --with-tune-32=mips32 --with-fp-32=xx
+ CONFARGS += --with-arch-32=mips32r2 --with-fp-32=xx
endif
endif
endif
ifneq (,$(findstring mips64-linux-gnuabi64,$(DEB_TARGET_GNU_TYPE)))
CONFARGS += --with-mips-plt
- CONFARGS += --with-arch-64=mips3 --with-tune-64=mips64
+ CONFARGS += --with-arch-64=mips64r2
ifeq ($(multilib),yes)
ifeq ($(biarchn32)-$(biarch32),yes-yes)
CONFARGS += --enable-targets=all
- CONFARGS += --with-arch-32=mips2 --with-tune-32=mips32 --with-fp-32=xx
+ CONFARGS += --with-arch-32=mips32r2 --with-fp-32=xx
endif
endif
endif