summaryrefslogtreecommitdiff
path: root/debian/rules2
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules2')
-rw-r--r--debian/rules224
1 files changed, 15 insertions, 9 deletions
diff --git a/debian/rules2 b/debian/rules2
index b029865..b38cbf5 100644
--- a/debian/rules2
+++ b/debian/rules2
@@ -252,6 +252,20 @@ else
--enable-shared \
--enable-linker-build-id \
+# we need libgcc shared since we use unwind functions from it,
+# not from libc, default is -static-libstdc++ and -static-libgcc.
+# We are lucky that we can use host libgcc, better way
+# could be hackery with LD_LIBRARY_PATH.
+ ifeq (illumos,$(DEB_TARGET_ARCH_OS))
+ CONFARGS += \
+ --enable-tls \
+ --enable-threads=posix \
+ --enable-libmudflap \
+ --with-boot-ldflags=-static-libstdc++ \
+ --with-gnu-as \
+ --with-gnu-ld
+ endif
+
ifneq ($(single_package),yes)
CONFARGS += \
--libexecdir=/$(libexecdir) \
@@ -587,7 +601,7 @@ ifeq ($(DEB_TARGET_ARCH_OS),linux)
endif
endif
-ifneq (,$(filter $(DEB_TARGET_ARCH), amd64 i386 kfreebsd-i386 kfreebsd-amd64))
+ifneq (,$(filter $(DEB_TARGET_ARCH), amd64 i386 kfreebsd-i386 kfreebsd-amd64 illumos-amd64))
ifneq (,$(filter $(derivative),Ubuntu))
ifneq (,$(filter $(distrelease),dapper hardy))
CONFARGS += --with-arch-32=i486
@@ -1311,14 +1325,6 @@ else ifneq (,$(filter $(build_type),build-cross cross-build-native cross-build-c
endif
@echo TTTTT $$(date -R)
s=`cat status`; rm -f status; \
- if [ $$s -ne 0 ] && [ -z "$$NO_CONFIG_LOG_DUMP$$NO_CONFIG_LOG_DUMPS" ]; then \
- for log in $$(find $(builddir) -name config.log); do \
- case "$$log" in */build/build-*|*/stage1-*|*/prev-*) continue; esac; \
- echo LOGFILE START $$log; \
- cat $$log; \
- echo LOGFILE END $$log; \
- done; \
- fi; \
test $$s -eq 0
if [ -f $(srcdir)/contrib/warn_summary ]; then \