summaryrefslogtreecommitdiff
path: root/debian/patches/kfreebsd-decimal-float.diff
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2019-11-19 17:35:47 +0300
committerIgor Pashev <pashev.igor@gmail.com>2019-11-19 17:35:47 +0300
commit03bebac19e6fef19299d7326d3ee41f8a7dd1316 (patch)
treebb413d22ada331790f08b7b9a592e5ab95cd8918 /debian/patches/kfreebsd-decimal-float.diff
parent94a19f31b81e9e7e295414fe2ad2302e0db25a08 (diff)
parent8f6c4b0033c72f8ac14694c419a99458339dd6a9 (diff)
downloadgcc-9-03bebac19e6fef19299d7326d3ee41f8a7dd1316.tar.gz
Merge tag 'debian/9.2.1-19'
Diffstat (limited to 'debian/patches/kfreebsd-decimal-float.diff')
-rw-r--r--debian/patches/kfreebsd-decimal-float.diff32
1 files changed, 32 insertions, 0 deletions
diff --git a/debian/patches/kfreebsd-decimal-float.diff b/debian/patches/kfreebsd-decimal-float.diff
new file mode 100644
index 0000000..4f87bca
--- /dev/null
+++ b/debian/patches/kfreebsd-decimal-float.diff
@@ -0,0 +1,32 @@
+# DP: Enable decimal float support on kfreebsd-amd64
+
+--- a/src/gcc/configure.ac
++++ b/src/gcc/configure.ac
+@@ -839,6 +839,7 @@ AC_ARG_ENABLE(__cxa_atexit,
+ [], [])
+
+ # Enable C extension for decimal float if target supports it.
++# touch the file, adding decimal support for kfreebsd-amd64 in config/dfp.m4
+ GCC_AC_ENABLE_DECIMAL_FLOAT([$target])
+
+ dfp=`if test $enable_decimal_float != no; then echo 1; else echo 0; fi`
+--- a/src/libdecnumber/configure.ac
++++ b/src/libdecnumber/configure.ac
+@@ -76,6 +76,7 @@ AC_CANONICAL_TARGET
+
+ # Default decimal format
+ # If you change the defaults here, be sure to change them in the GCC directory also
++# touch the file, adding decimal support for kfreebsd-amd64 in config/dfp.m4
+ AC_MSG_CHECKING([for decimal floating point])
+
+ GCC_AC_ENABLE_DECIMAL_FLOAT([$target])
+--- a/src/libgcc/configure.ac
++++ b/src/libgcc/configure.ac
+@@ -211,6 +211,7 @@ AC_CHECK_HEADERS(inttypes.h stdint.h std
+ AC_HEADER_STDC
+
+ # Check for decimal float support.
++# touch the file, adding decimal support for kfreebsd-amd64 in config/dfp.m4
+ AC_CACHE_CHECK([whether decimal floating point is supported], [libgcc_cv_dfp],
+ [AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
+ #include <fenv.h>