summaryrefslogtreecommitdiff
path: root/debian/patches/libgo-testsuite.diff
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2019-11-18 15:53:29 +0300
committerIgor Pashev <pashev.igor@gmail.com>2019-11-18 15:53:29 +0300
commit8f6c4b0033c72f8ac14694c419a99458339dd6a9 (patch)
tree06c106e622a58100aa85a381b9b65d222b076df4 /debian/patches/libgo-testsuite.diff
parent42156b5190f4fa150e1fab6777eb81e69d4db8c9 (diff)
downloadgcc-9-debian.tar.gz
Import gcc-9 (9.2.1-19)debian/9.2.1-19debian
Diffstat (limited to 'debian/patches/libgo-testsuite.diff')
-rw-r--r--debian/patches/libgo-testsuite.diff38
1 files changed, 26 insertions, 12 deletions
diff --git a/debian/patches/libgo-testsuite.diff b/debian/patches/libgo-testsuite.diff
index 34977ce..8231889 100644
--- a/debian/patches/libgo-testsuite.diff
+++ b/debian/patches/libgo-testsuite.diff
@@ -1,13 +1,20 @@
# DP: Only run the libgo testsuite for flags configured in RUNTESTFLAGS
-Index: b/src/libgo/Makefile.am
-===================================================================
--- a/src/libgo/Makefile.am
+++ b/src/libgo/Makefile.am
-@@ -2387,6 +2387,12 @@ CHECK = \
- export LD_LIBRARY_PATH; \
+@@ -828,7 +828,7 @@ BUILDGOX = \
+ $(SHELL) $(srcdir)/mvifdiff.sh $@.tmp `echo $@ | sed -e 's/s-gox/gox/'`
+
+ GOTESTFLAGS =
+-GOBENCH =
++GOBENCH =
+
+ # Check a package.
+ CHECK = \
+@@ -849,6 +849,12 @@ CHECK = \
$(MKDIR_P) $(@D); \
rm -f $@-testsum $@-testlog; \
+ files=`$(SHELL) $(srcdir)/match.sh --goarch=$(GOARCH) --goos=$(GOOS) --srcdir=$(srcdir)/go/$(@D) --extrafiles="$(extra_go_files_$(subst /,_,$(@D)))" $(matchargs_$(subst /,_,$(@D)))`; \
+ run_check=yes; \
+ MULTILIBDIR="$(MULTILIBDIR)"; \
+ case "$$MULTILIBDIR" in /64|/x32) \
@@ -15,9 +22,9 @@ Index: b/src/libgo/Makefile.am
+ esac; \
+ if test "$$run_check" = "yes"; then \
if test "$(USE_DEJAGNU)" = "yes"; then \
- $(SHELL) $(srcdir)/testsuite/gotest --goarch=$(GOARCH) --goos=$(GOOS) --dejagnu=yes --basedir=$(srcdir) --srcdir=$(srcdir)/go/$(@D) --pkgpath="$(@D)" --pkgfiles="$(go_$(subst /,_,$(@D))_files)" --testname="$(@D)" $(GOTESTFLAGS) $(go_$(subst /,_,$(@D))_test_files); \
+ $(SHELL) $(srcdir)/testsuite/gotest --goarch=$(GOARCH) --goos=$(GOOS) --dejagnu=yes --basedir=$(srcdir) --srcdir=$(srcdir)/go/$(@D) --pkgpath="$(@D)" --pkgfiles="$$files" --testname="$(@D)" $(GOTESTFLAGS); \
elif test "$(GOBENCH)" != ""; then \
-@@ -2402,6 +2408,7 @@ CHECK = \
+@@ -864,6 +870,7 @@ CHECK = \
echo "FAIL: $(@D)" > $@-testsum; \
exit 1; \
fi; \
@@ -25,14 +32,21 @@ Index: b/src/libgo/Makefile.am
fi
# Build all packages before checking any.
-Index: b/src/libgo/Makefile.in
-===================================================================
--- a/src/libgo/Makefile.in
+++ b/src/libgo/Makefile.in
-@@ -2394,6 +2394,12 @@ CHECK = \
- export LD_LIBRARY_PATH; \
+@@ -1007,7 +1007,7 @@ BUILDGOX = \
+ $(SHELL) $(srcdir)/mvifdiff.sh $@.tmp `echo $@ | sed -e 's/s-gox/gox/'`
+
+ GOTESTFLAGS =
+-GOBENCH =
++GOBENCH =
+
+ # Check a package.
+ CHECK = \
+@@ -1028,6 +1028,12 @@ CHECK = \
$(MKDIR_P) $(@D); \
rm -f $@-testsum $@-testlog; \
+ files=`$(SHELL) $(srcdir)/match.sh --goarch=$(GOARCH) --goos=$(GOOS) --srcdir=$(srcdir)/go/$(@D) --extrafiles="$(extra_go_files_$(subst /,_,$(@D)))" $(matchargs_$(subst /,_,$(@D)))`; \
+ run_check=yes; \
+ MULTILIBDIR="$(MULTILIBDIR)"; \
+ case "$$MULTILIBDIR" in /64|/x32) \
@@ -40,9 +54,9 @@ Index: b/src/libgo/Makefile.in
+ esac; \
+ if test "$$run_check" = "yes"; then \
if test "$(USE_DEJAGNU)" = "yes"; then \
- $(SHELL) $(srcdir)/testsuite/gotest --goarch=$(GOARCH) --goos=$(GOOS) --dejagnu=yes --basedir=$(srcdir) --srcdir=$(srcdir)/go/$(@D) --pkgpath="$(@D)" --pkgfiles="$(go_$(subst /,_,$(@D))_files)" --testname="$(@D)" $(GOTESTFLAGS) $(go_$(subst /,_,$(@D))_test_files); \
+ $(SHELL) $(srcdir)/testsuite/gotest --goarch=$(GOARCH) --goos=$(GOOS) --dejagnu=yes --basedir=$(srcdir) --srcdir=$(srcdir)/go/$(@D) --pkgpath="$(@D)" --pkgfiles="$$files" --testname="$(@D)" $(GOTESTFLAGS); \
elif test "$(GOBENCH)" != ""; then \
-@@ -2409,6 +2415,7 @@ CHECK = \
+@@ -1043,6 +1049,7 @@ CHECK = \
echo "FAIL: $(@D)" > $@-testsum; \
exit 1; \
fi; \