summaryrefslogtreecommitdiff
path: root/debian/patches/libstdc++-futex.diff
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2019-11-19 17:35:47 +0300
committerIgor Pashev <pashev.igor@gmail.com>2019-11-19 17:35:47 +0300
commit03bebac19e6fef19299d7326d3ee41f8a7dd1316 (patch)
treebb413d22ada331790f08b7b9a592e5ab95cd8918 /debian/patches/libstdc++-futex.diff
parent94a19f31b81e9e7e295414fe2ad2302e0db25a08 (diff)
parent8f6c4b0033c72f8ac14694c419a99458339dd6a9 (diff)
downloadgcc-9-03bebac19e6fef19299d7326d3ee41f8a7dd1316.tar.gz
Merge tag 'debian/9.2.1-19'
Diffstat (limited to 'debian/patches/libstdc++-futex.diff')
-rw-r--r--debian/patches/libstdc++-futex.diff337
1 files changed, 337 insertions, 0 deletions
diff --git a/debian/patches/libstdc++-futex.diff b/debian/patches/libstdc++-futex.diff
new file mode 100644
index 0000000..ebb4918
--- /dev/null
+++ b/debian/patches/libstdc++-futex.diff
@@ -0,0 +1,337 @@
+# DP: Fix GCC_LINUX_FUTEX to work with C99 compilers
+
+config/
+
+2019-09-06 Florian Weimer <fweimer@redhat.com>
+
+ * futex.m4 (GCC_LINUX_FUTEX): Include <unistd.h> for the syscall
+ function.
+
+libitm/ libgomp/ libstdc++-v3/
+
+2019-09-06 Florian Weimer <fweimer@redhat.com>
+
+ * configure: Regenerate.
+
+--- a/src/config/futex.m4
++++ b/src/config/futex.m4
+@@ -22,6 +22,7 @@ case "$target" in
+ AC_LINK_IFELSE(
+ [AC_LANG_PROGRAM(
+ [#include <sys/syscall.h>
++ #include <unistd.h>
+ int lk;],
+ [syscall (SYS_gettid); syscall (SYS_futex, &lk, 0, 0, 0);])],
+ [save_LIBS="$LIBS"
+@@ -48,6 +49,7 @@ If so, please configure with --disable-l
+ AC_LINK_IFELSE(
+ [AC_LANG_PROGRAM(
+ [#include <sys/syscall.h>
++ #include <unistd.h>
+ int lk;],
+ [syscall (SYS_gettid); syscall (SYS_futex, &lk, 0, 0, 0);])],[],
+ [AC_MSG_ERROR([SYS_gettid and SYS_futex required for --enable-linux-futex])])
+--- a/src/libitm/configure
++++ b/src/libitm/configure
+@@ -16481,6 +16481,7 @@ case "$target" in
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
+ #include <sys/syscall.h>
++ #include <unistd.h>
+ int lk;
+ int
+ main ()
+@@ -16533,6 +16534,7 @@ rm -f core conftest.err conftest.$ac_obj
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
+ #include <sys/syscall.h>
++ #include <unistd.h>
+ int lk;
+ int
+ main ()
+--- a/src/libgomp/configure
++++ b/src/libgomp/configure
+@@ -793,6 +793,7 @@ infodir
+ docdir
+ oldincludedir
+ includedir
++runstatedir
+ localstatedir
+ sharedstatedir
+ sysconfdir
+@@ -886,6 +887,7 @@ datadir='${datarootdir}'
+ sysconfdir='${prefix}/etc'
+ sharedstatedir='${prefix}/com'
+ localstatedir='${prefix}/var'
++runstatedir='${localstatedir}/run'
+ includedir='${prefix}/include'
+ oldincludedir='/usr/include'
+ docdir='${datarootdir}/doc/${PACKAGE_TARNAME}'
+@@ -1138,6 +1140,15 @@ do
+ | -silent | --silent | --silen | --sile | --sil)
+ silent=yes ;;
+
++ -runstatedir | --runstatedir | --runstatedi | --runstated \
++ | --runstate | --runstat | --runsta | --runst | --runs \
++ | --run | --ru | --r)
++ ac_prev=runstatedir ;;
++ -runstatedir=* | --runstatedir=* | --runstatedi=* | --runstated=* \
++ | --runstate=* | --runstat=* | --runsta=* | --runst=* | --runs=* \
++ | --run=* | --ru=* | --r=*)
++ runstatedir=$ac_optarg ;;
++
+ -sbindir | --sbindir | --sbindi | --sbind | --sbin | --sbi | --sb)
+ ac_prev=sbindir ;;
+ -sbindir=* | --sbindir=* | --sbindi=* | --sbind=* | --sbin=* \
+@@ -1275,7 +1286,7 @@ fi
+ for ac_var in exec_prefix prefix bindir sbindir libexecdir datarootdir \
+ datadir sysconfdir sharedstatedir localstatedir includedir \
+ oldincludedir docdir infodir htmldir dvidir pdfdir psdir \
+- libdir localedir mandir
++ libdir localedir mandir runstatedir
+ do
+ eval ac_val=\$$ac_var
+ # Remove trailing slashes.
+@@ -1428,6 +1439,7 @@ Fine tuning of the installation director
+ --sysconfdir=DIR read-only single-machine data [PREFIX/etc]
+ --sharedstatedir=DIR modifiable architecture-independent data [PREFIX/com]
+ --localstatedir=DIR modifiable single-machine data [PREFIX/var]
++ --runstatedir=DIR modifiable per-process data [LOCALSTATEDIR/run]
+ --libdir=DIR object code libraries [EPREFIX/lib]
+ --includedir=DIR C header files [PREFIX/include]
+ --oldincludedir=DIR C header files for non-gcc [/usr/include]
+@@ -4581,8 +4593,9 @@ fi
+ save_CFLAGS="$CFLAGS"
+
+ # Add -Wall -Werror if we are using GCC.
++# FIXME: -Werror fails in the x32 multilib variant
+ if test "x$GCC" = "xyes"; then
+- XCFLAGS="$XCFLAGS -Wall -Werror"
++ XCFLAGS="$XCFLAGS -Wall"
+ fi
+
+ # Find other programs we need.
+@@ -11393,7 +11406,7 @@ else
+ lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
+ lt_status=$lt_dlunknown
+ cat > conftest.$ac_ext <<_LT_EOF
+-#line 11396 "configure"
++#line 11409 "configure"
+ #include "confdefs.h"
+
+ #if HAVE_DLFCN_H
+@@ -11499,7 +11512,7 @@ else
+ lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
+ lt_status=$lt_dlunknown
+ cat > conftest.$ac_ext <<_LT_EOF
+-#line 11502 "configure"
++#line 11515 "configure"
+ #include "confdefs.h"
+
+ #if HAVE_DLFCN_H
+@@ -15376,7 +15389,7 @@ fi
+
+ # Plugins for offload execution, configure.ac fragment. -*- mode: autoconf -*-
+ #
+-# Copyright (C) 2014-2018 Free Software Foundation, Inc.
++# Copyright (C) 2014-2019 Free Software Foundation, Inc.
+ #
+ # Contributed by Mentor Embedded.
+ #
+@@ -15824,8 +15837,7 @@ for ac_func in aligned_alloc posix_memal
+ do :
+ as_ac_var=`$as_echo "ac_cv_func_$ac_func" | $as_tr_sh`
+ ac_fn_c_check_func "$LINENO" "$ac_func" "$as_ac_var"
+-eval as_val=\$$as_ac_var
+- if test "x$as_val" = x""yes; then :
++if eval test \"x\$"$as_ac_var"\" = x"yes"; then :
+ cat >>confdefs.h <<_ACEOF
+ #define `$as_echo "HAVE_$ac_func" | $as_tr_cpp` 1
+ _ACEOF
+@@ -15888,6 +15900,7 @@ case "$target" in
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
+ #include <sys/syscall.h>
++ #include <unistd.h>
+ int lk;
+ int
+ main ()
+@@ -15940,6 +15953,7 @@ rm -f core conftest.err conftest.$ac_obj
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
+ #include <sys/syscall.h>
++ #include <unistd.h>
+ int lk;
+ int
+ main ()
+--- a/src/libstdc++-v3/configure
++++ b/src/libstdc++-v3/configure
+@@ -871,6 +871,7 @@ infodir
+ docdir
+ oldincludedir
+ includedir
++runstatedir
+ localstatedir
+ sharedstatedir
+ sysconfdir
+@@ -995,6 +996,7 @@ datadir='${datarootdir}'
+ sysconfdir='${prefix}/etc'
+ sharedstatedir='${prefix}/com'
+ localstatedir='${prefix}/var'
++runstatedir='${localstatedir}/run'
+ includedir='${prefix}/include'
+ oldincludedir='/usr/include'
+ docdir='${datarootdir}/doc/${PACKAGE_TARNAME}'
+@@ -1247,6 +1249,15 @@ do
+ | -silent | --silent | --silen | --sile | --sil)
+ silent=yes ;;
+
++ -runstatedir | --runstatedir | --runstatedi | --runstated \
++ | --runstate | --runstat | --runsta | --runst | --runs \
++ | --run | --ru | --r)
++ ac_prev=runstatedir ;;
++ -runstatedir=* | --runstatedir=* | --runstatedi=* | --runstated=* \
++ | --runstate=* | --runstat=* | --runsta=* | --runst=* | --runs=* \
++ | --run=* | --ru=* | --r=*)
++ runstatedir=$ac_optarg ;;
++
+ -sbindir | --sbindir | --sbindi | --sbind | --sbin | --sbi | --sb)
+ ac_prev=sbindir ;;
+ -sbindir=* | --sbindir=* | --sbindi=* | --sbind=* | --sbin=* \
+@@ -1384,7 +1395,7 @@ fi
+ for ac_var in exec_prefix prefix bindir sbindir libexecdir datarootdir \
+ datadir sysconfdir sharedstatedir localstatedir includedir \
+ oldincludedir docdir infodir htmldir dvidir pdfdir psdir \
+- libdir localedir mandir
++ libdir localedir mandir runstatedir
+ do
+ eval ac_val=\$$ac_var
+ # Remove trailing slashes.
+@@ -1537,6 +1548,7 @@ Fine tuning of the installation director
+ --sysconfdir=DIR read-only single-machine data [PREFIX/etc]
+ --sharedstatedir=DIR modifiable architecture-independent data [PREFIX/com]
+ --localstatedir=DIR modifiable single-machine data [PREFIX/var]
++ --runstatedir=DIR modifiable per-process data [LOCALSTATEDIR/run]
+ --libdir=DIR object code libraries [EPREFIX/lib]
+ --includedir=DIR C header files [PREFIX/include]
+ --oldincludedir=DIR C header files for non-gcc [/usr/include]
+@@ -11845,7 +11857,7 @@ else
+ lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
+ lt_status=$lt_dlunknown
+ cat > conftest.$ac_ext <<_LT_EOF
+-#line 11848 "configure"
++#line 11860 "configure"
+ #include "confdefs.h"
+
+ #if HAVE_DLFCN_H
+@@ -11951,7 +11963,7 @@ else
+ lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
+ lt_status=$lt_dlunknown
+ cat > conftest.$ac_ext <<_LT_EOF
+-#line 11954 "configure"
++#line 11966 "configure"
+ #include "confdefs.h"
+
+ #if HAVE_DLFCN_H
+@@ -15637,7 +15649,7 @@ $as_echo "$glibcxx_cv_atomic_long_long"
+ # Fake what AC_TRY_COMPILE does.
+
+ cat > conftest.$ac_ext << EOF
+-#line 15640 "configure"
++#line 15652 "configure"
+ int main()
+ {
+ typedef bool atomic_type;
+@@ -15672,7 +15684,7 @@ $as_echo "$glibcxx_cv_atomic_bool" >&6;
+ rm -f conftest*
+
+ cat > conftest.$ac_ext << EOF
+-#line 15675 "configure"
++#line 15687 "configure"
+ int main()
+ {
+ typedef short atomic_type;
+@@ -15707,7 +15719,7 @@ $as_echo "$glibcxx_cv_atomic_short" >&6;
+ rm -f conftest*
+
+ cat > conftest.$ac_ext << EOF
+-#line 15710 "configure"
++#line 15722 "configure"
+ int main()
+ {
+ // NB: _Atomic_word not necessarily int.
+@@ -15743,7 +15755,7 @@ $as_echo "$glibcxx_cv_atomic_int" >&6; }
+ rm -f conftest*
+
+ cat > conftest.$ac_ext << EOF
+-#line 15746 "configure"
++#line 15758 "configure"
+ int main()
+ {
+ typedef long long atomic_type;
+@@ -15896,7 +15908,7 @@ $as_echo "mutex" >&6; }
+ # unnecessary for this test.
+
+ cat > conftest.$ac_ext << EOF
+-#line 15899 "configure"
++#line 15911 "configure"
+ int main()
+ {
+ _Decimal32 d1;
+@@ -15938,7 +15950,7 @@ ac_compiler_gnu=$ac_cv_cxx_compiler_gnu
+ # unnecessary for this test.
+
+ cat > conftest.$ac_ext << EOF
+-#line 15941 "configure"
++#line 15953 "configure"
+ template<typename T1, typename T2>
+ struct same
+ { typedef T2 type; };
+@@ -15972,7 +15984,7 @@ $as_echo "$enable_int128" >&6; }
+ rm -f conftest*
+
+ cat > conftest.$ac_ext << EOF
+-#line 15975 "configure"
++#line 15987 "configure"
+ template<typename T1, typename T2>
+ struct same
+ { typedef T2 type; };
+@@ -18270,8 +18282,22 @@ else
+ fi
+
+
++ if test x$enable_libstdcxx_debug = xyes; then
++ if test -f $toplevel_builddir/../stage_final && test -f $toplevel_builddir/../stage_current; then
++ stage_final=`cat $toplevel_builddir/../stage_final`
++ stage_current=`cat $toplevel_builddir/../stage_current`
++ if test x$stage_current != x$stage_final ; then
++ skip_debug_build=yes
++ enable_libstdcxx_debug=no
++ fi
++ fi
++ fi
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: $enable_libstdcxx_debug" >&5
+ $as_echo "$enable_libstdcxx_debug" >&6; }
++ if test x$skip_debug_build = xyes ; then
++ { $as_echo "$as_me:${as_lineno-$LINENO}: Skip libstdc++-v3 debug build for bootstrap stage $stage_current" >&5
++$as_echo "$as_me: Skip libstdc++-v3 debug build for bootstrap stage $stage_current" >&6;}
++ fi
+
+
+
+@@ -78741,6 +78767,7 @@ fi
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
+ #include <sys/syscall.h>
++ #include <unistd.h>
+ int lk;
+ int
+ main ()
+@@ -78799,6 +78826,7 @@ fi
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
+ #include <sys/syscall.h>
++ #include <unistd.h>
+ int lk;
+ int
+ main ()