summaryrefslogtreecommitdiff
path: root/debian/rules.d/binary-d.mk
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2019-11-19 17:35:47 +0300
committerIgor Pashev <pashev.igor@gmail.com>2019-11-19 17:35:47 +0300
commit03bebac19e6fef19299d7326d3ee41f8a7dd1316 (patch)
treebb413d22ada331790f08b7b9a592e5ab95cd8918 /debian/rules.d/binary-d.mk
parent94a19f31b81e9e7e295414fe2ad2302e0db25a08 (diff)
parent8f6c4b0033c72f8ac14694c419a99458339dd6a9 (diff)
downloadgcc-9-03bebac19e6fef19299d7326d3ee41f8a7dd1316.tar.gz
Merge tag 'debian/9.2.1-19'
Diffstat (limited to 'debian/rules.d/binary-d.mk')
-rw-r--r--debian/rules.d/binary-d.mk28
1 files changed, 23 insertions, 5 deletions
diff --git a/debian/rules.d/binary-d.mk b/debian/rules.d/binary-d.mk
index 434fcc6..d9f8e82 100644
--- a/debian/rules.d/binary-d.mk
+++ b/debian/rules.d/binary-d.mk
@@ -4,8 +4,10 @@ ifneq ($(DEB_STAGE),rtlibs)
endif
arch_binaries := $(arch_binaries) gdc
- ifeq ($(with_libphobos),yes)
+ ifeq ($(with_libphobosdev),yes)
$(lib_binaries) += libphobos-dev
+ endif
+ ifeq ($(with_libphobos),yes)
$(lib_binaries) += libphobos
endif
@@ -77,7 +79,7 @@ endif
files_gdc = \
$(PF)/bin/$(cmd_prefix)gdc$(pkg_ver) \
- $(gcc_lexec_dir)/cc1d
+ $(gcc_lexec_dir)/d21
ifneq ($(GFDL_INVARIANT_FREE),yes-now-pure-gfdl)
files_gdc += \
$(PF)/share/man/man1/$(cmd_prefix)gdc$(pkg_ver).1
@@ -96,12 +98,12 @@ $(binary_stamp)-gdc: $(install_stamp)
rm -rf $(d_gdc)
dh_installdirs -p$(p_gdc) $(dirs_gdc)
- dh_installdocs -p$(p_gdc) src/gcc/d/README
+ dh_installdocs -p$(p_gdc)
dh_installchangelogs -p$(p_gdc) src/gcc/d/ChangeLog
$(dh_compat2) dh_movefiles -p$(p_gdc) -X/zlib/ $(files_gdc)
-ifeq ($(with_libphobos),yes)
+ifeq ($(with_phobos),yes)
mv $(d)/$(usr_lib)/libgphobos.spec $(d_gdc)/$(gcc_lib_dir)/
endif
@@ -129,9 +131,18 @@ endif
/$(docdir)/$(p_gcc)/README.Bugs \
/$(docdir)/$(p_gdc)/README.Bugs
+ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTONS)))
+ $(DWZ) \
+ $(d_gdc)/$(gcc_lexec_dir)/d21
+endif
dh_strip -p$(p_gdc) \
- $(if $(unstripped_exe),-X/cc1d)
+ $(if $(unstripped_exe),-X/d21)
dh_shlibdeps -p$(p_gdc)
+
+ mkdir -p $(d_gdc)/usr/share/lintian/overrides
+ echo '$(p_gdc) binary: hardening-no-pie' \
+ > $(d_gdc)/usr/share/lintian/overrides/$(p_gdc)
+
echo $(p_gdc) >> debian/arch_binaries
find $(d_gdc) -type d -empty -delete
@@ -181,6 +192,13 @@ define __do_libphobos
,$(2)) \
$(if $(filter yes, $(with_common_libs)),,-- -Ldebian/shlibs.common$(2))
$(call cross_mangle_substvars,$(p_l))
+
+ $(if $(2),
+ mkdir -p $(d_l)/usr/share/lintian/overrides; \
+ echo "$$pkgname binary: embedded-library" \
+ >> $(d_l)/usr/share/lintian/overrides/$(p_l)
+ )
+
dh_lintian -p$(p_l)
echo $(p_l) $(p_d) >> debian/$(lib_binaries)